TomTom XL IQ routes keeps disconnecting from PC while trying to backup

Discussion in 'Technical Support' started by Butras, Aug 22, 2019.

  1. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    tried the windows 10 scan and repair tool
    it says
    upload_2019-8-25_18-8-21.png
     
    Butras, Aug 25, 2019
    #21
    1. Advertisements

  2. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    and chkdsk in command prompt - how odd...
    upload_2019-8-25_18-10-23.png
     
    Butras, Aug 25, 2019
    #22
    1. Advertisements

  3. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    could this explain what's going on i wonder
    the sat corresponds to when i first plugged it in to this PC and found i had a problem.
    upload_2019-8-25_18-46-32.png
     
    Butras, Aug 25, 2019
    #23
  4. Butras

    Arno Moderator

    Joined:
    Jun 3, 2008
    Messages:
    3,375
    Likes Received:
    78
    Location:
    Toronto - Pickering, ON
    TomTom Model(s):
    930; GO 620; Start 63
    Maybe a silly suggestion but in the olden days if I couldn't move a file, I changed one letter in the extension, moved it and then changed it back.
     
    Arno, Aug 25, 2019
    #24
  5. Butras

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,816
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Yikes! Well spotted.

    A 1390 VID correctly indicates TomTom. Why 4146? That belongs to a USBest flash drive, likely the last thing plugged into that physical port. The 442 error code (and more often 441) are always reported with this error.

    This particular problem seems to be showing up lot for Win10 users with external drives. Oddly, the best solution has been to try hooking up to a much older machine to extract the data from the external drive .. err, in this case, TomTom. What's weird is that the VID, PID and serial number displayed in the first always make sense, so most of the low level USB comms that occur right after connection seem to have worked. What will be odder is that you'll see the TomTom device in Device Manager and most likely, it won't be flagged as having any issues.

    I have yet to see a cogent explanation for this. Essentially, what Windows is claiming is that it was unable to assign the new device to that physical USB port (even though it likely shows up in Device Manager as operational) and instead, advises you as to what was previously connected. When using an external drive, this is sometimes because the drive isn't yet initialized, or of it is, not 'named' for Windows purposes. Here's what is often quoted from MS:

    Step 1:

    1. Open Run Command (Windows button +R), a dialog box will open type "diskmgmt.msc".
    2. Disk management window will open, check if there is a yellow exclamation mark besides the HDD drive. If so I would suggest that you update the driver through the WD website.

    If you do not locate the yellow exclamation mark follow the step below



    Step 2: In the same disk management window, check if the HDD drive has been named/allocated. If not follow the steps below:

    1. Right-click it on the HDD and select “New Volume.” This will open a Setup Wizard.
    2. Click on the on screen instruction and select and allocate a name for the drive.
    3. Restart your system and check if the issue persist.


    However, when that doesn't fix things, no one at Microsoft has ever, as far as I can tell, properly explained why this might be the case, nor have they provided a solid remedy for it. It usually plagues external USB hard/SSD drive users.

    Let us know what you see for this USB device in Device Manager -- in particular, whether it gets the yellow flag and "Unknown" label.
     
    Last edited: Aug 26, 2019
    canderson, Aug 26, 2019
    #25
  6. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    Thanks again!

    on trying to follow the steps you gave I run into a slight hitch
    can open diskmgmt OK
    there was no yellow exclamation mark so I went on to step 2
    upload_2019-8-26_10-26-59.png

    but the right click options for the TomTom ( listed as Internal (E:) are not quite as expected
    upload_2019-8-26_10-25-28.png

    I have also tried uninstalling the USB device in device manager - then plugging it back in to teh same or a differnt USB port on the rear but the same issue seems to keep reoccurring

    in device manager it looks like this
    upload_2019-8-26_10-30-1.png
    upload_2019-8-26_10-30-53.png
    upload_2019-8-26_10-35-16.png

    the driver seems very old - so I tried update driver option in device manager - (search and update the driver automatically) but it said the current driver is the most up to date so i don't think it changed anything.

    I then uninstalled the USB storage device - disconnected the tomtom cable - reconnected it and allowed the PC to find it and re-install it - but as you can see in the last screenshot - it reinstalled it but with the device not migrated error message again - this was last night so has the 25/08/2019 date

    upload_2019-8-26_10-44-40.png
    Windows seems to get buggier and buggier each year!
     
    Last edited: Aug 26, 2019
    Butras, Aug 26, 2019
    #26
  7. Butras

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,816
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    That's one for Microsoft, I'm afraid. Do you have access anywhere to an older box?
     
    canderson, Aug 26, 2019
    #27
  8. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    thanks again.
    yeah, i guess so. :(
    i have a v old xp laptop i use to talk to the car - can try that for a backup - but will persevere to try to fix issues with my main pc.
    i assume i could manually update the mass storage device driver to something more current
    there are plenty listed for the win 10 64 bit system that are much newer than the one currently used - so i would hope that would be a fix - as i read that the basic issue is that the operating system is basically incorrectly identifying which driver it should be using for the malfunctioning device ( if that's true)
     
    Butras, Aug 26, 2019
    #28
  9. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    Butras, Aug 26, 2019
    #29
  10. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    Hmmm. not sure I should be happy or sad at this but - The "device not migrated due to partial or ambiguous match " thing seems to be a red herring....
    exactly the same issues are occurring when trying to copy over the contents of the tomtom with the windows xp laptop.....
    at least we can now be confident that its a TomTom issue
     
    Butras, Aug 26, 2019
    #30
  11. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    just trying a few things to attempt to find a way forward
    today the device manager says the TomTom internal drive is working properly ( as usual) but this time chkdsk seems to think there are errors.
    after 3 attempts it says it has fixed them....

    upload_2019-8-27_11-49-10.png
    SyncToy could complete the echo synch of the drive as a result
    upload_2019-8-27_11-52-28.png

    There were three *.CHK type files created in a folder called FOUND by the chkdsk program.
    these were all small 32kb in size and contains a lot of random text and some names of places that were recently visited - and some not visited for years
    hopefully this means they were just some history or favorites type files and not central to the device's main function...
    upload_2019-8-27_12-2-34.png
    the device still boots normally, can find gps satelite signal and navigate to a favourite address - so so far so good
    will i think attempt a clean copy and paste of the entire drive as hopefully a more solid backup
    then try an update...
     
    Butras, Aug 27, 2019
    #31
  12. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    OK - so the clean copy of the internal drive was done without a hitch.
    I then tried a backup via the tomtom Home 2 software - also fine
    I have now run the update the system and maps etc via TomTom Home 2 and the device seems just fine.
    so for anyone with the same issue - it looks like its caused by errors in the tomtoms internal file system, which Windows doesn't always seem to reliably recognize.
    However, after many attempts with windows check disk tool, it did seem to find and fix them after which the device backup / update functionality seems to be restored.
    As far as I can tell the "device not migrated" type error in windows is still present but appears to be a side issue as even large MAP files will now transfer successfully.
    Thank you to all who contributed to try to assist,
    I hope it is of use to somebody else. :)
     
    Butras, Aug 27, 2019
    #32
  13. Butras

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,976
    Likes Received:
    441
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    dhn, Aug 27, 2019
    #33
  14. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    Butras, Aug 27, 2019
    #34
  15. Butras

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,816
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Whew. As I recall, the whole point was to update your device, and that you were trying (wisely) to back up before the update.
    In order to assure that you have a truly clean and safe backup, I would now copy BACK all of the files from your PC to your device and see if it operates normally.
    If it does, then and only then would I go ahead and let Home perform the requisite update(s).
     
    canderson, Aug 27, 2019
    #35
  16. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    good advice - as you can see above since the device was of little use to me as it was - i went ahead and updated - including maps, etc - i do not seem to have had any file copying or updating issues since fixing the file system on the tomtom drive - so all appears well for now - only time will tell i guess - will use it and see how it goes.
    Thanks again for your help.
     
    Butras, Aug 28, 2019
    #36
  17. Butras

    Arno Moderator

    Joined:
    Jun 3, 2008
    Messages:
    3,375
    Likes Received:
    78
    Location:
    Toronto - Pickering, ON
    TomTom Model(s):
    930; GO 620; Start 63
    Congratulations. Your tenacity and patience paid off.
     
    Arno, Aug 28, 2019
    #37
  18. Butras

    Butras

    Joined:
    Aug 22, 2019
    Messages:
    23
    Likes Received:
    0
    TomTom Model(s):
    TomTom One XL IQ routes
    reset home address and a few display settings that were lost = device is working normally - telling the correct time - and displaying time of arrival properly now. Thanks again.:)
     
    Butras, Aug 30, 2019
    #38
  19. Butras

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,816
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    After all these years, that little ONE XL certainly didn't own you anything, but it's great that it has been resurrected! Be sure to keep that good working backup on your PC just in case it's ever needed again.
     
    canderson, Aug 30, 2019
    #39
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.