Flashing red X after failed update

Discussion in 'Technical Support' started by asdf1234, May 7, 2019.

  1. asdf1234

    asdf1234

    Joined:
    May 7, 2019
    Messages:
    6
    Likes Received:
    0
    TomTom Model(s):
    N14644
    Model: n14644

    What happened:
    GPS unit wasn't keeping time. Decided to do an update to try to fix it.
    Plugged in unit to computer with TomTom Home 2 installed. TT2 updated itself.
    Ran "Update My Device" which found a new software update and a new maps update.
    While copying files over it ran into "error writing file data.chk".
    I rebooted the device

    Now, it seems dead. When I turn it on I get a red flashing X and refuses to connect to the computer.
    I tried the step here: http://uk.support.tomtom.com/app/an...ion-device-not-starting-or-displaying-a-cross
    What happens is I can successfully boot into the bootloader/BIOS type of thing as evidenced here:
    [​IMG]



    But when I tap three times fast to boot into recovery mode, it just goes to the flashing red X again and will not connect to the PC.

    I'm pretty mad, because it's blindly obvious that TomTom's awful update software just bricked my device. It was running 100% perfectly fine before I ran the update, besides the clock being out of whack.

    Is there anything else to try? I'm technically competent and willing to do anything and everything to get this device running including cracking it open.
     
    asdf1234, May 7, 2019
    #1
    1. Advertisements

  2. asdf1234

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,814
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Your device is what we call an older "Nav2" era unit, so we may be able to help you sort this by pointing you to some older firmware. HOWEVER, success is predicated upon being able to 'see' your device with your PC when it is connected. We don't care what the device or Home says - only that it looks like an external storage device to the PC, which may or may not be possible at this point. We need the device to discover that two new files have been placed in its root directory. If the root isn't visible, we'll have a look at another tool to see what kind of USB issues might exist, but it's not hopeful at that point.

    Assuming that you CAN see something that resembles an external storage device with your PC...

    Everything (in particular, your "RU" serial number) says that your device is (variously, depending upon market) an XL IQRoutes TTS, a 335, or a 340S.
    I assume that your device actually is equipped with Text-To-Speech (can pronounce street and town names, etc.) Correct?

    This may get a little complicated, but 'technically competent' may just be enough to get us through this!

    One strange thing --- do you have any idea what version firmware was running on your device before this last update? I ask, because the bootloader you have is 5.5136, which is really quite old, indicating that the firmware on your device was probably quite old and not updated for some time. So it appears we will be jumping forward a bit.

    Start by following this link, which should generate a download of the 9.061 code for your device:
    http://download.tomtom.com/sweet/navcore/9.061.xxl2009_tts.CAB-navcore-XXL.cab

    That file will include not only a decent version of firmware (yes, 9.061) but will also include a compatible bootloader to go along with it.
    Once you have that in hand, get back to us, and we'll discuss the possibility of getting it installed.
     
    canderson, May 7, 2019
    #2
    asdf1234 likes this.
    1. Advertisements

  3. asdf1234

    asdf1234

    Joined:
    May 7, 2019
    Messages:
    6
    Likes Received:
    0
    TomTom Model(s):
    N14644
    Hey Canderson, first off thank you so much for reaching out!

    I got it hooked up to the PC and it is displaying as an external storage device! For some reason that wasn't working at all yesterday but today she's alive!! TomTom Home 2 does not recognize the device as connected though.

    The full serial is RU1390100626 - yes, it can pronounce street and town names. Under the serial number it says "(4EM0.001.02)". Sorry to say but I haven't the foggiest what the firmware may have been.

    I have that .cab file in hand and ready and awaiting further instruction! Let me know if there's further device info you need. As I said, I'm a software developer and know my way around a terminal so if there's any poking or prodding you'd like me to do I'm capable and happy to do so.
     
    asdf1234, May 8, 2019
    #3
  4. asdf1234

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,814
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Excellent. OK, here's where we find out how this is going to play. Since we don't know which version of code you had, but since you had an old bootloader, which implies old code as well, everything should move FORWARD in the process regardless of where you were.

    First, we want to copy EVERYTHING from your device to your PC for temporary safekeeping. That allows a certain amount of recovery if things start to go south. HOWEVER, we will be moving to a new bootloader / firmware combo, not just firmware, so we're going to have to take them as a pair, and there's no backing up on bootloaders. When the device discovers something more recent in a bootloader than it has seen before, it gets loaded -- a one way trip since this goes into an area of NVRAM that isn't accessible to us.

    So ...

    Back up your entire device to your PC into one big folder's worth. You probably won't need it, but here's our method >> https://www.tomtomforums.com/thread...-to-the-computer-and-how-to-restore-it.17864/
    On the whole, this is ALWAYS preferable to using Home to do a backup, because Home overwrites every previous backup with the current one, so if you have issues, you can wind up overwriting an old GOOD backup with JUNK!

    The *.cab file, as you probably already know, is just another way of saying *.zip. We need for you to unzip the full content of the *.cab file into the ROOT of your device.

    Once that is done, you'll need to perform a PROPER logical USB disconnect of your device using whatever OS technique fits your OS.

    Cross your fingers, unplug the TomTom, and perform a hard reset. That entails nothing more than holding the power button until you see the logo, then hear the drum sounds begin, then releasing it right away.

    We can discuss what we do with Home and this latest week rollover update after we see the results.
     
    Last edited: May 8, 2019
    canderson, May 8, 2019
    #4
    asdf1234 likes this.
  5. asdf1234

    asdf1234

    Joined:
    May 7, 2019
    Messages:
    6
    Likes Received:
    0
    TomTom Model(s):
    N14644
    Awesome, I'll get right on that after work today! One point of clarification though:

    "The *.cab file, as you probably already know, is just another way of saying *.zip. We need for you to unzip the full content of the *.cab file into the ROOT of your device."

    To be clear, I should delete all the contents off the storage device before doing this, right? Is formatting the card a good idea or just normal file deletion? If I should format, what filesystem am I going for?
     
    asdf1234, May 8, 2019
    #5
  6. asdf1234

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,975
    Likes Received:
    441
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Make a full manual backup of your unit's contents. Canderson's post above yours provides a link how to do that. Formatting the device should not be necessary.

    Then delete all the loose files in the root of your device (those NOT in a folder).

    Then extract the contents of the cab file using WinRAR to the device.
     
    dhn, May 8, 2019
    #6
    asdf1234 likes this.
  7. asdf1234

    asdf1234

    Joined:
    May 7, 2019
    Messages:
    6
    Likes Received:
    0
    TomTom Model(s):
    N14644
    I really shouldn't delete any of the folders or their contents in the root directory? From looking at the cab contents it looks like there's a fair bit of overlap. In that case, do I overwrite any files where there are conflicts?

    For posterity's sake, here is the ls output of the drive:

    Code:
    drwxrwxrwx  1 jocquej  staff    32768 May  8 12:46 .Spotlight-V100
    drwxrwxrwx  1 jocquej  staff    32768 May  8 12:46 .fseventsd
    -rwxrwxrwx  1 jocquej  staff   348160 May 11  2010 InstallTomTomHOME.exe
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 LoquendoTTS
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 North_America_P
    -rwxrwxrwx  1 jocquej  staff  8177884 Jun 16  2015 PNDNavigator
    drwxrwxrwx  1 jocquej  staff    32768 May 26  2008 TomTom HOME Install.app
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 TomTom-Cfg
    -rwxrwxrwx  1 jocquej  staff   391736 Jun 22  2010 antitheftw.bmp
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 art
    -rwxrwxrwx  1 jocquej  staff      186 Jun 22  2010 autorun.inf
    -rwxrwxrwx  1 jocquej  staff       51 Aug  4  2009 bootloaderversion.txt
    drwxrwxrwx  1 jocquej  staff    32768 Dec 31  1999 contacts
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 cp
    -rwxrwxrwx  1 jocquej  staff       33 Apr 19 14:28 currentmap.dat
    -rwxrwxrwx  1 jocquej  staff        0 May  6 18:10 data.chk
    -rwxrwxrwx  1 jocquej  staff        0 May  6 17:52 data_im2.chk
    -rwxrwxrwx  1 jocquej  staff  1194268 Jun 16  2015 data_is2.chk
    -rwxrwxrwx  1 jocquej  staff  5119621 Jun 16  2015 data_lim.chk
    -rwxrwxrwx  1 jocquej  staff  3205205 Jun 16  2015 data_lis.chk
    -rwxrwxrwx  1 jocquej  staff    75833 Jun 16  2015 data_ra.chk
    -rwxrwxrwx  1 jocquej  staff    20027 Jun 16  2015 data_sp.chk
    -rwxrwxrwx  1 jocquej  staff   347596 Jun 16  2015 data_ts.chk
    drwxrwxrwx  1 jocquej  staff    32768 Jan  1  2000 ephem
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 helpme
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 home images
    -rwxrwxrwx  1 jocquej  staff       13 Jun 22  2010 internal.dat
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 itn
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 licences
    drwxrwxrwx  1 jocquej  staff    32768 Dec 31  1999 logging
    -rwxrwxrwx  1 jocquej  staff   391736 Jun 22  2010 lowbatteryw.bmp
    drwxrwxrwx  1 jocquej  staff    32768 Jun 16  2015 maps
    -rwxrwxrwx  1 jocquej  staff      298 May 24  2017 mapshareupdate.xml
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 raster
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 schemes
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 script
    -rwxrwxrwx  1 jocquej  staff      993 May  6 21:46 settings.dat
    drwxrwxrwx  1 jocquej  staff    32768 Dec 31  1999 sounds
    -rwxrwxrwx  1 jocquej  staff   391736 Jun 22  2010 splashw.bmp
    drwxrwxrwx  1 jocquej  staff    32768 Aug  5  2011 statdata
    -rwxrwxrwx  1 jocquej  staff   391736 Jun 22  2010 suspendw.bmp
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 text
    -rwxrwxrwx  1 jocquej  staff    70596 Jun 22  2010 tomtom.ico
    -rwxrwxrwx  1 jocquej  staff       43 May  6 17:48 tthome.bif
    -rwxrwxrwx  1 jocquej  staff       68 May  6 21:46 userpatch.dat
    drwxrwxrwx  1 jocquej  staff    32768 Jul 12  2010 voices
    -rwxrwxrwx  1 jocquej  staff    29725 Apr 19 14:29 watchdogtrace.dat
    
    art, script, loquendoTTS et cetera are on the drive already so do I really not want to delete those?
     
    asdf1234, May 8, 2019
    #7
  8. asdf1234

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,975
    Likes Received:
    441
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    WinRAR will overwite as necessary.
     
    dhn, May 8, 2019
    #8
    asdf1234 likes this.
  9. asdf1234

    asdf1234

    Joined:
    May 7, 2019
    Messages:
    6
    Likes Received:
    0
    TomTom Model(s):
    N14644
    Oh my god, you guys it worked! Thank you thank you!!

    Is there anything else I should check before calling it good to go? Like should I double check that the maps aren't factory default or anything like that?

    The clock is still busted but honestly I'm kinda scared to do anything else now that the base navigation is working. If I were interested in attempting to fix that, what would the steps be?
     
    asdf1234, May 8, 2019
    #9
  10. asdf1234

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,814
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Glad we've gotten it this far. You're actually ahead of the game now since I'm sure you've got more updated firmware than you did before. No need to worry about maps. The unit can only fit one version, and it's going to be the one that was already present when we updated the firmware... entirely different content.

    At this point, do another full backup using the procedure outline above, so that you've captured a fully working device to your PC.

    As to what to do next .. there's the rub. Yours is the first Nav2 device that I've seen 'bricked' by a wnro update (a few Nav3 devices not so lucky). One would suspect that the update that is now pending for your new firmware isn't going to cause you the same heartburn as this last one, but at least with a full backup, you can regroup. If the clock situation becomes an issue (it would be for me, since ETA would always be jacked up), give Home one more try at providing updated firmware.

    As noted earlier, I was interested to see that whatever firmware version you recently received, it did NOT also include an update to the bootloader, and honestly, I would have not been surprised that there was a malfunction there. Both firmware and corresponding bootloader code had been updated numerous times since whatever level was previously on your device. I am guessing that your antique bootloader and the new firmware they sent to you or the wnro were no longer compatible. Great job of configuration control there (not).

    Hey, do you still have the previously downloaded wrno firnware *.cab file in a folder called (variously, depending upon OS level)
    C:\Documents and Settings\yourname\My Documents\TomTom\HOME\Downloads\complete\program
    or
    C:\Users\Owner\Documents\TomTom\HOME\Download\complete\program

    If you do, I'd be very interested in the exact filename of that *.cab file and whether that *.cab file included in its root not just a file called ttsystem (the firmware) but also a file called system (the bootloader). If the latter was absent, that points further to a potential configuration control issue where new and old may not have mixed well.
     
    canderson, May 9, 2019
    #10
    asdf1234 likes this.
  11. asdf1234

    asdf1234

    Joined:
    May 7, 2019
    Messages:
    6
    Likes Received:
    0
    TomTom Model(s):
    N14644
    The update worked without issue! Clock is fixed and I'm a very very happy camper. I will admit that I wasn't a good scientist and used my Mac rather than the PC that originally caused the issues for the update.

    I've uploaded 9.541.2-2042-CAB-navcore-LE.cab here: https://mega.nz/#!615jjAbS!lyq0oQL7cr9EPqddNaScEHiydBfdC_SG4APC7jQMM5I
    Spoilers though, it has ttsystem but no system. So seems you're right, TomTom screwed the pooch by trying to update to a much higher firmware than my bootloader was capable of handling. Thanks so much for having the necessary bootloader around to get me up to speed and updating again :]

    Thank you both so so much for your help and expertise, especially you canderson! You guys are doing a great service and it's a shame you aren't on TomTom's payroll :p
     
    asdf1234, May 10, 2019
    #11
  12. asdf1234

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,814
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Glad we could help. If anyone wonders why we treasure the open system concept of the older units, this was certainly a prime example. There's nothing like this that we could do to repair any of the current models.
     
    canderson, May 10, 2019
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.