How to copy waypoints from a Garmin to a TomTom?

Discussion in 'Technical Support' started by TonyKiwiGPS, Oct 20, 2019.

  1. TonyKiwiGPS

    TonyKiwiGPS

    Joined:
    Oct 20, 2019
    Messages:
    3
    Likes Received:
    0
    TomTom Model(s):
    Start 52
    I've used Garmin devices, maily outdoor, for about 20 years and never TomTom until a customer asked to have 232 waypoints (or Favorites) transferred from his Garmin nuvi to his wife's TomTom Smart 52 (NZ new).

    Firstly I use myDrive Connect to update the maps and software. This appeared to go OK according the About info in the device.

    I used GPSBabel to convert the Garmin .gpx file to .ov2 format and then used mydrive.tomtom.com to try to import the file into the attached TomTom.

    I've tried importing the 5KB .ov2 file tried a few times, following the mydrive screen prompts and info but when I look at the TomTom > My Places there is nothing new in there. All I can see in My Places is Home, Recent destinations, Add Work, Marked locations.

    I also referred to the TomTom advice here
    Transferring items from MyDrive to your navigation device
    https://au.support.tomtom.com/app/answers/detail/a_id/19658

    Are there any steps I'm missing?

    Why on earth is it so difficult to import a common .gpx fie with waypoints (no tracks) into a TomTom?

    In the device > Cloud symbol MyDrive >
    Network Status = Connected
    Speed Camera Updates = Activated
    MyDrive = Logged in . I had a look in here and could see an unfamiliar gmail.com email address. with the word 'demo' in it. I logged out of that. Naturally I don't know their password so will try writing to the email address but don't expect an answer. The owner of the TomTom has never registered it or had it connected to a computer. He did say however that he asked a local retail shop to transfer the data. When he came back they said they had but there was no new info in My Places.

    Thank you, Tony
     
    Last edited: Oct 20, 2019
    TonyKiwiGPS, Oct 20, 2019
    #1
    1. Advertisements

  2. TonyKiwiGPS

    Arno Moderator

    Joined:
    Jun 3, 2008
    Messages:
    3,418
    Likes Received:
    82
    Location:
    Toronto - Pickering, ON
    TomTom Model(s):
    930; GO 620; Start 63
    Arno, Oct 20, 2019
    #2
    1. Advertisements

  3. TonyKiwiGPS

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,888
    Likes Received:
    184
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    It sounds like an account/login issue is causing the issues.

    GPSBabel is an excellent tool - I suspect we've used it for similar purposes along with GSAK which uses GPSBabel 'under the hood' for file conversion. It absolutely creates properly formatted TomTom *.ov2 files. I use it weekly for that purpose. I noted that you said "Why on earth is it so difficult to import a common .gpx fie with waypoints (no tracks) into a TomTom?" Just so we are clear, the only *.gpx file that can be directly imported to a TomTom (using the web interface, of course) IS a track <trkpt> style *.gpx file. But I think I understand what you actually meant.

    I assume that your original *.gpx is indeed in the <wpt> format. GPSBabel will definitely correctly cross-convert a *.gpx of that particular flavor to an *.ov2. I typically use GSAK for that purpose, but Babel is the engine there.

    Let's focus on the account situation.

    Once you have set up an account on the MyDrive web system ( https://mydrive.tomtom.com/en_au/ ) with an email and password, that is the EXACT email and password that must be used on the device as well. I noted your comment about some random email address on MyDrive web, so wanted to be sure that the device and web account and email ARE in sync. You can get traffic & etc on the device regardless of whether there's a correct web account set up, but having the two match is what is critical to moving *.ov2 files to the device.

    Post #5 here https://www.tomtomforums.com/threads/upgrading-from-xxl540-to-go520.32451/ shows the screens involved in uploading the *.ov2 files.

    Note the use of the underscored filename _Favorites.ov2 to push the favorites list to the top of the MyPlaces list.
     
    canderson, Oct 20, 2019
    #3
  4. TonyKiwiGPS

    TonyKiwiGPS

    Joined:
    Oct 20, 2019
    Messages:
    3
    Likes Received:
    0
    TomTom Model(s):
    Start 52
    Many thanks for the quick and comprehensive help! The screen shots looked familiar to what I was seeing in Mydrive. I could see the .ov2 file I'd uploaded and could delete it. But it would not appear in the device itself.

    As you say, I also suspect that the unknown email registration in the device is the problem. I've had no answer from the 'demo' gmail address so will give the TomTom back to the owner as he'll have to track down the retail shop assistant and see what he did to it. If that fails hopefully he can contact TomTom and get the unit reset back to factory with no registration in it.

    Such are the joys of the strictly 'on-line' method of handling data. This assumes we have an operating internet system so is a rather 'elitist' requirement for a simple navigation device. Agreed, to update software and maps an internet connection is required but an off-line method of handling waypoints / tracks etc should always be available. Garmin have gone the same 'on-line' way with their ridiculous and very expensive Android based Overlander which cannot accept maps or data via BaseCamp. It won't even zoom in below 60 degrees South. There's one at Scott Base, Antarctica at the moment (77 South) and is proving to be useless - fortunately they have it on loan, not bought.

    Thanks again, Tony
     
    Last edited: Oct 20, 2019
    TonyKiwiGPS, Oct 20, 2019
    #4
  5. TonyKiwiGPS

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,888
    Likes Received:
    184
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Wish I could be more help. However, I would first try a factory reset of the device, then a fresh email/password combination on the device to get logged into the TomTom servers. That should put you in the correct state.
     
    canderson, Oct 21, 2019
    #5
    TonyKiwiGPS likes this.
  6. TonyKiwiGPS

    TonyKiwiGPS

    Joined:
    Oct 20, 2019
    Messages:
    3
    Likes Received:
    0
    TomTom Model(s):
    Start 52
    Thank you for the Reset suggestion. I tried that and sure enough the email registration on the device disappeared. So I went through the process of importing the .ov2 file again and activated the registration with the same email and password as myDrive and the Connect systems.

    The .ov2 file is OK I think as it opened correctly in the POI Edit programme.

    I was disappointed to find the POI's still did not import to My Places. So I gave up and have offered the customer a nuvi at a discounted price.

    Below this thread are several similar questions in the "Similar Threads" section but they were not any help.

    But thanks for trying to help, I appreciate it :)
     
    TonyKiwiGPS, Oct 21, 2019
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.