Go 720 "problem with map" error after firmware update

Joined
Feb 29, 2008
Messages
86
Hooked up Go 720 to PC, and it said there was updates available, this time it looked like a firmware update as well as map corrections etc. Let it do its thing, now the unit won't work at all, just get the error "You cannot use this map on this device: North_America_2GB-132"

So, now I can't even get into the unit to see what navcore I have, any ideas here? Is it forcing me to buy a new map to get it operational now?


thanks
 
Have you tried using the reset hole on the bottom of the unit?

Also, is the map on the unit one that was obtained legitimately from TomTom? (sorry, but have to ask.....)
 
I have the same problem with my 720. I did the old standby of backing up everything using a separate backup program, reinstalling the cfg file so I have all my favorites, then using Home to change one of my favorites but the TomTom just keeps cycling and rebooting. I've tried the changing of favorites several times but still no luck. I update my map every 3 months and I really get tired of doing all these gyrations everytime. You would think they would have fixed this known bug, especially since they sell the map update package. Any suggestion other than going and doing a full reinstallation from my backup?
 
Copnnect to Home and run the emulator (Operate my unit). Plan a trip. Then disconnect properly from Home using the Device Disconnect icon.

See if that helps.
 
For clarification, dhn, do you mean use the "plan A to B" route for "plan trip", or just a "Navigate to" operation?
 
Finally got it working but had to go through step 5 of the Tomtom Acting Up? -Part 1 - First Steps In System Recovery. Hopefully next map update goes better.:cool::cool:
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,017
Messages
196,003
Members
67,998
Latest member
prosperot

Latest Threads

Back
Top