Can't use Operate My Go on a Go520

Jul 6, 2010
TomTom Model(s)
Go 520
I have a Tom|Tom Go 520(T) which works fine but after a recent (and the latest) update to TomTom Home when I try to use "Operate My Go" I see the message "Downloading needed file" which seems to stay unchanged for ages then fails.
The full error message is:
ERROR: XPInstall/-228/# XPInstall error:
Installing add-on: (e-mail address removed) (Emulator)
Severity: 1105
0. chrome://tthome/content/logic/model/ttAddon.js:673
error = new XPInstallError(value, this._updateItem);

Can anyone help please?
Did you actually accept when it said you needed to download a file?

Are you connected by a wireless computer or directly connected?

Did you try exiting Home completely (make sure it's not running in the background in the notification area) and restart Home?

Do you actually have application 8.351 installed on your unit?

Things to check..............
Hi and thanks for getting back so quickly.

Yes I did accept the prompt.
I'm connected via the USB cradle.
I have shut down and restarted the entire machine not just TomTom Home.
I do have 8.351 installed.
I uninstalled TomTom completely then re-installed but still get the same error.
I notice the error includes the line:
Installing add-on: (e-mail address removed) (Emulator)

but in Manage My Go under Applications it says the version currently installed is 8.351
Sometimes, Windows' uninstall routine (or Home's itself) doesn't really clean out all remnents of the program.

1. Go here and download the FREE version of Revo Uninstaller.
2. Run it and choose to uninstall Home. Choose choice 4, which digs into the registry
3. After that is done, try downloading Home again, installing and see if there are any better results.....
I did as you said (I like that Revo Uninstaller) but unfortunately it still hasn't worked. Same error.
I tried the pin reset. No luck.

I downloaded the clear flash tool from TomTom, ran it 3 times and still no luck.
I've tried that link several times now from IE, Chrome and Firefox with the same results.
To begin with the download will actually start but get to (at most) 6% then simply stall.
It doesn't fail, there's no error messages, it simply stops.
On subsequent attempts (even after rebooting) it stalls earlier in the process until it doesn't download anything at all. No error messages. To all intents and purposes the download appears to begin but nothing happens.

I'm running Windows Vista Home Premium with 4Gb of RAM.
I use AVG as my antivirus and no specific firewall.
Hi guys,

Well I tried the workaround you suggested but still no joy.

Before I edited the host file I pinged and it responded just fine.
I went ahead and changed it anyway. It again pinged fine.

I even tried the c++ redistributable but no luck there either.

I can download generally from the internet and I can get the gpsfix updates and other stuff from tomtom.
The only thing I can't do is "Operate My Go".
Okay, had to scroll back to see what's been tried and what hasn't.......

First question, what application do you have on the 520? Anything below 8.351 is not current, anything above 8.351 is not correct for your unit?

If when tapping the satellite bars, the next screen does NOT show 8.351, then do the following in order:

1. Make an Explorer, not Home, backup of your unit's contents.
2. Use Explorer to delete all the loose files in the root of the unit, NO folders or their contents.
3. Try downloading the proper application from here.
4. If you can't download it, restore your backup from step 1.
5. If you CAN download it, use Winrar to extract the contents of the cab file to your computer, overwriting existing files if prompted.
6. Disconnect the unit from the computer properly (Hardware Device disconnect), restart the unit and connect to Home. See if things are better now.........
After many failed attempts I finally managed to download the cab file.

I made my Explorer backup.
Deleted the loose files from the root of the device.
Extracted the cab to the device, overwriting existing files
Removed the device, ejecting from TTHome then Safely Removing from Explorer.
Restarted the device (and logged in)

I now get a message "Application update required"
I click "update my device" and it says "No items available".

When I go Back there is a new icon "Get free map corrections from Map Share" but when I click on it I get the message "TomTom Map Share is not supported either for your device or for the map you are using."

I then tried "Update my go" and got the message "You cannot use this feature because it is not supported by your device."
After disconnecting the device and turning it on it prompted me to Join Map Share - which I did.
When I re-connected (via the usb cradle) the map share icon had gone.

I then tried 'Update my go' again.... and the same old problem was there!!
Well, I have to ask..........

What map do you have on your device and where did you get it? Did you get the 520 directly from TomTom???
The map is UK and ireland version 810.1870 which I got from TomTom under the latest map guarantee.
The device came from a large,reputable retail outlet.
I'm sorry........

I guess I'm missing something but I just don't know what else to suggest.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Latest member

Latest Threads