XL 330 and Windows 7 64 bit - TT Home does not see connected device

Joined
Jan 12, 2010
Messages
2
Location
Australia
TomTom Model(s)
XL 330
Anyone got this device working with TomTom Home (latest version from TomTom) using Win 7 64?

Ever since I upgraded by machine to Win 7 64-bit (was no problem I think under Win 7 32-bit), TomTom Home refuses to see my device (says device not connected).

However, I can access the device data via Windows Explorer (device appears as type "ONE XL (v9)" ), and even the balloon tip when I hover over TomTom Home icon in the system tray says device connected - yet the main window of TT Home shows device not connected - hence can't update or operate from TT Home application (ie, tells me to connect device).

I note the device still connects and updates fine using TT Home on my other Windows XP computer, so it's only on the Win 7 64-bit OS that TT Home refuses to see it.

I have even tried installing XP Mode in Win 7 64 and running TT Home in that virtual machine - but still TT Home does not see the device. Also have uninstalled device drivers and the application and deleted user application files, then reinstalled from scratch - still no luck with TT Home.

My next step I think will be to reformat device back to original contents as at time of purchase to see if I've messed something up. But given the device currently works fine under XP, I'm really thinking it could be a TT Home-device driver incompatability under Win 7 64 with this particular model?

Any links or suggestions would be appreciated.

TIA.
 
You are not the first to mention issues with Home and a 64 bit operating system. While some have no problems, others, such as yourself, do.

Hopefully TT will come out with a more robust Home application that will deal with the problem.
 
I'm using Win 7 64 bit on two PCs (one laptop, one desktop) and the most recent version of TT Home on both of them. I don't have any issues connecting to my One XL-S. I know it's not the same unit as yours, but Win 7 64 is not an issue with me.
 
Thanks - finally bit the bullet and restored the device to original navcore - the device is now recognised by TT Home under Win 7 64. So guess it was the navcore that was incompatible with TT Home, but only under Win 7 x64 for some reason.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,081
Messages
196,586
Members
68,091
Latest member
ziviani

Latest Threads

Back
Top