TomTom GPS XL 330 stuck after update

Joined
Dec 20, 2011
Messages
7
Hello.

I've been trying to get my GPS up and running again after foolishly attempting to update it. I haven't updated it since I bought and the first time I did, it won't function properly. Every time I start it up, I hear the TomTom sign and log and hear the drum intro and then it stays stuck on a screen with a picture of a GPS and what looks like a cd drive on the bottom left of the screen. It still connects to the computer but I can't do anything to make it work.

What I did was:
I connected it to the PC, and installed TomTom home. It prompted an update which i accepted but it encountered an error. I attempted it several times getting different errors:

Error writing file: H:\antitheftw.bmp
Error writing file: H:\bootloaderversion.txt

The update application is named 8.083.xl2008_t.CAB-navcore-ONEXL and is under
C:\Users\______\Documents\TomTom\HOME\Download\complete\program\TomTom_Application_for_TomTom_XL

I have searched this forum, and tried all the solutions i found:
Hard reset (nope)
Deleting files outside of the main folders (Nothing)
Getting rid of Mapsettings.cfg (Still nothing)

I'm very tired of this and I just wanna get my GPS up working once more. Please somebody lend me a hand.

Thank you for your time.
 
do you mean just extracting the files straight into the GPS?

I have not yet, because I don't really know if all the files on the update belong on the root folder or what not.
 
When you use WinRar, it will maintain the file structure of the various files/folders in the cab folder.

Overwrite as necessary, if asked.
 
After trying to extract, i got :


! C:\Users\_____\Documents\TomTom\HOME\Download\complete\program\TomTom_Application_for_TomTom_XL\8.083.xl2008_t.CAB-navcore-ONEXL.cab:
Write error in the file antitheftw.bmp. Probably the disk is full
 
Sounds as if the downloaded file itself may be corrupt.

Anyway, do an Explorer, not Home, backup of your unit's contents. If not sure how, see here: https://www.tomtomforums.com/t17864-how-backup-contents-your-unit-computer.html

Then format the unit. Don't use quickformat.

Use WinRar again to try the installation of the application.

Restore the specific map folder to the unit from the backup you made.
 
Any chance you are operating on a Mac? Whether or not that is the case, it sounds to me as though the complaint is that you are not successful in moving files to the device. In the case of a Mac, that's because of a strange approach they have to trash on external storage devices like thumb drives and your TomTom. Let us know either way.
 
Sorry for the late response. Christmas shopping at the last minute.

I cannot even perform a simple copy and paste. I made the back up folder, highlighted and copied all the content and tried to paste to the folder but it doesn't do anything. I can see the pointer change to an hourglass, processing but it doesn't paste them to the back up folder. I tried on both my laptop and my desktop but neither will let me copy.

Also, I'm using an Asus laptop, running Windows 7.
 
Another thing is, when I plug the GPS on my laptop, Windows shows the followeing message:

Do you want to scan and fix INTERNAL (H:)? (TomTom GPS)

"There might be a problem with some files on the device or disc. This happens can happen if you remove the device or disc before all files have been written on it"

I know assume that the device got disconnected why the update was happening, although I did not removed it manually during and now it won't let me copy anything out of it.

I'll run the scan and see if it gets better.
 
We've seen Win7 users often prompted to do the scan, often the first time they plug in. Usually finds nothing amiss with the device, but that seems to clear the issue for Win7. It's as though Win7 assumes a 'dirty' device by default, and the scan clears that bit.
 
Ok, i extracted the update, restored the folders (replacing when prompted)
It appeared to respond by showing a yellow loading bar at the bottom but then the TomTom logo appeared and now it won't go pass there.

I am seriously loosing hope here :(

Anywho, i'll leave it for a few minutes see if it responds. If not, I'll redo all the procedures again and see if will work once and for all.
 
Before i formatted it again and restored, I tried to operate my using TomTomHome and it worked perfectly and all updates were added correctly but now it won't go past the start up logo screen and it resets on its own. Any idea how to solve this problem now?
 
Connect to Home. run the emulator (Operate my Unit). Plan a trip. Disconnect properly from Home using the Device Disconnect icon.

Any better?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Staff online

Members online

Latest resources

Forum statistics

Threads
29,156
Messages
197,159
Members
68,213
Latest member
JMS

Latest Threads

Back
Top