Please help with my XL (30 Series) / 330 - 1GB

Joined
Mar 6, 2012
Messages
28
Location
UK
TomTom Model(s)
XL IQ Routes / 340 - 2GB - XL IQ Routes Edition Europe
Hi All,

OK, so I have just updated my device via TomTom home and it failed to boot correctly, just kept getting to the select voice screen and then cycling through the start-up sequence. I have never had to restart the config from an update. A bit weird to start with! Tried a device reset by holding the power button, same problem.

Anyway, started by deleting my mapsettings.cfg file from the device, which usually does the job after a map update, but to no avail. Then remembering when I had issues when first got the device (about two years ago), I backed up the device to my machine using windows copy (Windows XP Pro) with all hidden files shown etc so that I didn't miss anything. Then I formatted the device to FAT32 and copied the files back ensuring that mapsettings.cfg was not there. Now it hits the boot screen and just sits there.

Followed the same process again with FAT format (instead of FAT32) and same thing. Hit the boot screen and does nothing. Reading through the forums and suggestions reformatted again to FAT32 as this seems to be the preferred method, and used TomTom home to re-install to factory default, downloaded just the basics, i.e. got rid of my custom screens etc, and the map updates, literally back to the beginning. Still same issue, hits the TomTom start screen and just does nothing. Left it until the battery ran out.

Gave the device an overnight charge then used the "Hold power button for 20 seconds" to get the boot loader screen, then again (for 15 seconds) to reset the device, got the bongo sounds, then hit the start screen logo and nothing!

I have run ChkDsk with repair and fix, no errors found. Device has full formatted space available, all the files are there, just doesn't work. Surely I don't need to go and sepnd another couple of hundred to replace a device that I've only had two years with continuos updates to software and maps for the period (roughly every three months!)

I don't have a previous backup in TomTom home of the pre-update settings, as I have not had this problem before.

Seems that the latest Map and software update has trashed my TomTom device. Not happy considering I spend £79 to get map updates!!

Please help! I depend on my TomTom for work, crap at reading maps!!

Cheers
Claudio

------
** Claudio Fiore **
TOMTOM XL IQ Routes Edition (2GB)
UK and Western Europe Maps
Edition: XL (30 Series) / 330 - 2GB
 
Thanks will give that a try, I am just ensuring I have a full backup again. I can operate the device currently though TomTom home, even though it wont boot up!

But will definitely give the Clear Flash utility a try. At present I'll try anything! :) I've even considered trying to throw it against a wall! But I wont do that of course (yet) :D!
 
Try running the Clear Flash tool on the device (3 times). It is found here:
http://us.support.tomtom.com/app/answers/detail/a_id/6211/kw/clear%20flash

Once you do that, connect the unit to Home and plan a trip using the emulator (Operate my Unit). Then disconnect from Home using the Device Disconnect icon.

See if that helps.

I was able to set up a route in Home (operate my device) and that worked, but once disconnected from Home still the same problem. After Clearing the cache and planning a route in the Home screen. Device restarts after disconnect from Home and just sits on the startup image. Does not go into navigation. Any other suggestions would be greatly appreciated.

Can I send or show you anything that might shed some light?

Cheers
Claud
------
** Claudio Fiore **
TOMTOM XL IQ Routes Edition
UK and Western Europe Maps
Edition: XL (30 Series) / 330 - 2GB
 
Did that (reformatted the device and re-installed from Home). But will try it again. Which application? TomTom Home or the device application?
 
OK, will try again. Thanks for the prompt responses! :)

Will let you know shortly.
 
Did you run the Clear Flash tool?

Yes did that before uninstalling the application on the device. Although this time I got a flashing white X in a round red circle. Never seen that before. The application is re-installing on the device now...
 
Oddly, the device never asks me if I want to connect to Home or the PC anymore, it just simply connects! Device has app re-installed again now, no maps or anything. Just the application.

OK, I am now further than I have been in a few days! The device now boots and goes through the setup process as if it is new. Got to the clock screen to set the time (which is correct) click on next, device hangs and restarts. Maybe because there is nothing on it except the application...

I'll reinstall the basics voices and current map and see what happens.

Cheers
Claud.
 
If you can get to the info page in the menu (or the boot page) it might help to tell us the bootloader version and the application version you have on it. (I probably won't be able to say for sure myself, but one of the other mods may have a compatibility list that's more extensive than mine!)
 
If you can get to the info page in the menu (or the boot page) it might help to tell us the bootloader version and the application version you have on it. (I probably won't be able to say for sure myself, but one of the other mods may have a compatibility list that's more extensive than mine!)

OK, the map is still installing. If it still fails to boot, I can get into the bootloader window by holding the power button down for 20 seconds. Cant actually get to the info page, as the device wont get that far! :)

If I need to I'll post the details on the boot loader window from the device. May take a pic, there's quite a bit of info on there!
 
OK, not sure that this helps or not, but my device is actually XL IQ Routes / 340 - 2GB Apologies, my eyesight is not what it used to be! Serial starts with RS not RB!

Not sure how much of a difference this makes. Seriously though I wish TomTom devices were USB 2.0! Data transfer of the map is taking a while! (Always did!).
 
The GO models and some of the other newer ones *are* USB2.0.

For the Ones and XLs I guess they had a very big bucket of USB 1 chips left over that they want to use up (or they bought them cheap!)
 
OK I now have the following installed on the device;

1 x Application - v8.415
1 x Voice (Chiara Italian) - v4
1 x Map - v845.2645 (Western_and_Central_Europe_2GB)

Nothing else, no other mods etc, all basics.

Now the machine boots, but again goes through the setup process and then after I hit done on the setting the time window it halts and restarts again. Keeps just doing this cyclic motion. Never gets past the setting clock window. Of course this is further than it has been in a couple of days since the last update. Done this more than 5 times now, still the same thing...

Boot loader v.S5.277 clist#342886 RVCT Image below! Sorry its a bit blurry! :)

Boot screen:
BOOTLOAD_SCREEN_2.jpg
 
And now it just sits at the TOMTOM start screen again! D'oh!
 
Just found an updated app in HOME, I guess I should try it... V9.401

Just downloading and installing it now.
 
Unusually, now I cant operate my device from HOME application! :(
 
Sorry, was typing this and missed your last three replies...
(which all add up)

Right, I think we MIGHT be getting somewhere...

Firstly as an aside, I think you need to change your forum signature! The "XL IQ Routes Edition" is a very different beast to the older "ONE XL"

Now... v8.415... That's a very old application version, and unless I very much mistaken about what model you really have, I think you should be on v9.061 or v9.401 for a non-LIVE "XL IQ Routes Edition".

Are you ABSOLUTELY SURE the serial number starts with RS? It does look like it from the screen-shot.

I suspect the device must have been on a more recent software version at some point and the bootloader has been updated, so the older version of software is refusing to run with it.

BUT (here's where my knowledge starts to get flakey...) I would have thought it would refuse to load at all, not get through to the clock settings screen.

It's a mystery why you aren't being offered a newer version of software, but I think we can dig out a link for a copy of v9.061 to try on it.

Before we go any further, let's just wait for some second opinions though!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,140
Messages
197,001
Members
68,188
Latest member
Moges

Latest Threads

Back
Top