Rider 400 and later Mount dock teardown

Joined
Apr 7, 2024
Messages
13
Country
<img src="/styles/default/custom/flags/de.png" alt="Germany" /> Germany
TomTom Model(s)
RIDER 410 PRO
Has anyone ever managed to cannabilise the innards of the car charging mount to use on the motorbike once the pins wear out? - the car one takes USB obvs but i was wondering if the circuit boards can be switched out.

Ive searched youtube for a teardown but to no avail - i also dont have a Torx that small so havent been able to open my own one up.

thanks in advance

J
 
Has anyone ever managed to cannabilise the innards of the car charging mount to use on the motorbike once the pins wear out? - the car one takes USB obvs but i was wondering if the circuit boards can be switched out.

Ive searched youtube for a teardown but to no avail - i also dont have a Torx that small so havent been able to open my own one up.

thanks in advance

J
The automotive dock connections aren't the same as the Rider series connections, so you won't find any replacements in automotive units that could be used for this purpose.
 
Im not in interested in the back ends - the front is the same and the pins are on the circuitboard. hence why requesting a teardown
The automotive dock connections aren't the same as the Rider series connections, so you won't find any replacements in automotive units that could be used for this purpose.
 

Attachments

  • IMG_1981.jpeg
    IMG_1981.jpeg
    599 KB · Views: 13
  • IMG_1983.jpeg
    IMG_1983.jpeg
    825.1 KB · Views: 13
If anyone has advise on why this gap (creating a whole load of vibration) has happened and what I can do to fix please I would be most grateful. It feels as if a spring has moved as its not loose, you can feel resistance when you try and push it back to its "normal" position. Many thanks.
 

Attachments

  • IMG_7166.JPG
    IMG_7166.JPG
    522.2 KB · Views: 6
If anyone has advise on why this gap (creating a whole load of vibration) has happened and what I can do to fix please I would be most grateful. It feels as if a spring has moved as its not loose, you can feel resistance when you try and push it back to its "normal" position. Many thanks.
yes - remove the mount from the thicker plate at the back (4 large bolts you can undo with an Allen key / hex key) - you will then find that your Size 5 torx screws in the middle part have either come loose or sheared and you can hopefully replace these - picture here indicates larger screws you have to undo and then the smaller screws that will have come loose
 

Attachments

  • IMG_2014.jpeg
    IMG_2014.jpeg
    764.9 KB · Views: 7
  • IMG_2015.jpeg
    IMG_2015.jpeg
    756 KB · Views: 7
Thanks for this. God knows what’s happened here?? Might need a new unit
 

Attachments

  • IMG_7180.jpeg
    IMG_7180.jpeg
    811.8 KB · Views: 8

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
28,976
Messages
195,679
Members
67,959
Latest member
31Den

Latest Threads

Back
Top