My tomtomxxl530t does not show correct time. Keeps jumping back to 12:00.

Discussion in 'Technical Support' started by Jangles53, Jun 16, 2019.

  1. Jangles53

    Jangles53

    Joined:
    Jun 16, 2019
    Messages:
    2
    Likes Received:
    0
    TomTom Model(s):
    Xxl530t
    My tomtom xxl 530t does not show correct time. Keeps jumping back to 12:00.
     
    Jangles53, Jun 16, 2019
    #1
    1. Advertisements

  2. Jangles53

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,934
    Likes Received:
    436
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Have you connected to Home for an important update?
     
    dhn, Jun 16, 2019
    #2
    1. Advertisements

  3. Jangles53

    Jangles53

    Joined:
    Jun 16, 2019
    Messages:
    2
    Likes Received:
    0
    TomTom Model(s):
    Xxl530t
    No I haven't because I'm not familiar with that.
     
    Jangles53, Jun 16, 2019
    #3
  4. Jangles53

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,934
    Likes Received:
    436
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    If you don't have Home, get it at tomtom.com/getstarted. Make sure you click the proper link for Home, NOT MyDriveConnect.
     
    dhn, Jun 16, 2019
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.