Unable to enter Activation Code


Joined
May 21, 2012
Messages
3
Location
California
TomTom Model(s)
XXL 540
Hi all,

just received my new XXL 540 and am trying to initiate the "Lifetime Maps" subscription that came with the unit. I have downloaded TomTom Home and am able to click on the "activation code" link. But after I have entered the code I get this message:

"The activation code you entered is valid but the associated product doesn''t work with your device type or with the version of the application you have installed on it. Please install the latest version of the device application by clicking ''Update my device'' in the main menu. Then enter your activation code again."

When I go to "Update my device" I am informed that there are no updates available as I'm already updated.

What gives???

thanks for your help...
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,211
Location
Toronto Canada
TomTom Model(s)
Go 50; Go 520
Call CS (don't email) with the activation code found on the card marked DO NOT DISCARD.

The number is 866-486-6866.
 
Joined
May 24, 2012
Messages
2
im having the same problem, is there another way to fix this, im in mexico and is not easy for me to call to USA
 
Joined
May 24, 2012
Messages
2
just found a spanish spoken numer, called and in 5 minutes problem was solved, thanks.
 
Joined
May 21, 2012
Messages
3
Location
California
TomTom Model(s)
XXL 540
Thanks. Call was easy and the CS rep entered the code for me. New maps downloaded without issue. Thanks again
 
Ad

Advertisements

Joined
May 27, 2012
Messages
9
Location
Canada
TomTom Model(s)
XL 340TM
I just had the exact same problem, but I seem to have solved it. What I did was:

- I noticed that the update process renamed the TomTom removable drive to INTERNAL, so I renamed it back to the original name TomTom
- I unplugged the GPS and rebooted it (hold On button 15 sec)
- I logged out in TomTom Home, killed it and restarted it, logged in again
- Reconnected the GPS, and it prompted me to enter my Activation code right away, which was accepted.

I did contact TomTom support by email to follow up, and they got back to me within 24 hours to confirm that Lifetime Maps was already activated on my account.

I'm not sure exactly which part of what I did was the solution, but it worked for me. Either it doesn't reset everything for the updated unit and prompt for the activation code until you restart, or there's a software screwup in TomTom Home that causes it to think a unit with the drive name INTERNAL is not the same valid GPS unit.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top