TomTom update memory card issue

Joined
Sep 12, 2010
Messages
12
Hi

I need to upload the updates to my tomtom unit regarding the latest issues. I need to install a SD card, but whichever card I use, it is not recognized my tomtom. I am on Mac. I used 8GB and 16GB cards. Reformatted them with the instructions from tomtom, but no success.

Anybody had this problem?

btw. I have a 630 unit

Thanks for any input.
 
The new firmware (I assume that's what you are updating) should replace the old without memory issues, but ...

So you have formatted the card using FAT32, and the device doesn't 'see' it? Let's start this way to eliminate some possible issues:

Plug your device into your Mac and see if Home sees both the device's internal memory and the card.
 
Thank you for responding. Yes, The update. It sees the both. I couldn't update because of lack of space. I used FAT32 as well as the PC format. Neither worked. I deleted the maps and updated the GPS that way. Now I have to figure out what's with the no valid card issue and put the maps onto the card.
 
My GO 930 which I got in June 2008 can take SDHC cards but "micro" SD cards are not recognised.
I only bought a 4GB card at the time as they were quite dear then. I never bought an 8GB straight SDHC card at the time and they have not been available when I tried to find one 18 months ago.

I believe the 630 is a newer device but you could have that same problem too.
 
Hi
That's what I am thinking. It maybe the case that the 8 or 16MB card is not readable. I don't think I can buy a 4MB card these days :) Why would 8MB card be any different?
 
Just to be 1000% sure -- what firmware is your device showing currently installed? Having no idea when you might have updated this device before, there IS a possibility that the previous firmware was old enough that it wouldn't recognize anything beyond 2GB. We just don't know the history.

Regardless of that -- BEWARE! There's a huge issue with any Mac and thumb drives, SD cards, and other external storage devices. Any trash that is generated stays in the LOCAL TRASH CAN OF THE DEVICE! I think the PC approach to putting the trash on the PC's hard drive makes a lot more sense, because you can run out of memory on your 630 and never know why! You must, with the device connected to your Mac, be sure you've emptied ITS trash else the memory is never freed up.

Just as you would for your 'regular' hard drive on your Mac, your TomTom has been allocated a trash can by the OS. It gets emptied just like your 'regular' trash can.
Ctrl-click your trash when your TomTom 'drive' is open in Finder and select "Empty Trash". I think you may find you have more available internal memory on your 630 after that.
The SAME goes for SD cards. They have their own trash as well. Make sure those get emptied properly.
 
It maybe the case that the 8 or 16MB card is not readable.
Why would 8MB card be any different?
If thrue, I think the problem is that your SD cards are carriers with Micro SD cards inside.
In my case it is that it does NOT recognise the Mircro SD card, only the straight SDHC card of which 8GB ones are as scarce as hen's teeth.
 
FWIW, I've never had a failure to read a uSD card inside an SD card carrier. The electrical and logical format of both cards is the same. Only the package size is different. So the move up to the bigger format with the carrier shouldn't have any impact on it. Even my old 740 Live was put together with uSD in an SD carrier. No issues. Arno - makes me wonder about the carrier(s) you were using.
 
Even my old 740 Live was put together with uSD in an SD carrier. No issues. Arno - makes me wonder about the carrier(s) you were using.
I did not pay attention about models in those day but I think the 630 was not an X30 but came out after your 740.
If so, the microSD card should work.
On the other hand, remember when I reported that a map updatement on my 930 screwed up my internal and CS Tech worked a day to get rid of the Europe map on the 4GM straigh SDHC tand installed the NAM map on it. At that time I tried several 8 GB micoSDs cards with several different carriers. Also,

https://www.tomtomforums.com/threads/go-730-no-memory-but-new-card.29123/#post-170452
 
There was a time when Home got completely confused about whether maps were going to the internal or external, but that was Home issue.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,047
Messages
196,335
Members
68,048
Latest member
Cranbrook

Latest Threads

Back
Top