Problem loading my routes into TomTom Go App

Joined
Jan 26, 2024
Messages
4
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
TomTom Go App
I am involved with organizing driving events for a classic car club & we have previously used a mixture of Garmin/TomTom Sat navs with GPX files and Google Maps. However Google Maps does not do what we need and the TomTom Go app provides a very good alternative for mobile phone users and can accept .gpx route files. I loaded it on my phone with the associated MyDrive on my phone & laptop and after a number of false starts its all working well. Routes can be imported and loaded onto the app which is just what we need.

The problems started when I tried to set up my friends phone to do the same thing. With his account we went through all the stages and got to the point where the routes was available on the phone on the MyDrive app, but not showing in the Go app. After playing around with this for some time which included deleting and reinstalling the MyDrive app on his phone, I decided to try another option and log him out and login on both MyDrive and the TomTom Go app as me and aside from having to reinstall the MyDrive app for it to work, all my routes were there.

However when I repeated this and signed in with his sign in, it wasn't working! Aghh.

The main steps I followed are outlined below:-

  • Went to https://mydrive.tomtom.com website and created an account. Bookmark site, set up account & Log in.
  • On Phone, used Google Play to install TomTom Go and TomTom My Drive apps. Open TomTom Go and set up payment for the account.
  • Opened the My Drive app and Logged in in using the same details as used to set up the account on the computer.
  • We then went back to the computer and imported a .gpx file, selected it, clicked on finish, save and sync route.
  • The route appeared on the MyDrive App on the phone, but not on the GO app.
  • Realised that we also had to log in on the Go App, using the same login in details.
  • Still no routes showing on the Go App.
  • I next deleted my friends log in details from both the My Drive and Go Apps and then deleted and reinstalled the MyDrive app on his phone. Then I logged in using to both using my account and the synced routes on my computer's MyDrive appeared.
  • Know the system was working I tried logging in as him again, but despite following the same procedure no routes appeared in the Go App.
From past experience I know that a lot of our entrants will be needing assistance with this, I need to find out the cause of my difficulties so does anyone have any ideas please?

Thanks

Howard
PS My phone runs Android 12.0 & his runs Android 13 with the ColorOS 13.0 skin
 
Hello Howard,

From what I understand you're importing a GPX file using MyDrive web on a computer and then select the sync option to bring it as a track to the GO Navigation app. You do not need the MyDrive app in this. The long you sync the route and are logged in with the correct account in GO Navigation it should just work.

Just to make sure we're talking about the same thing, here's a screenshot of the sync option on plan.tomtom.com (which is about to replace MyDrive web):

Screenshot 2024-01-29 110558.png
 
You used to be able to sync it as a route, with all of its waypoints. You can't seem to do that now by de-selecting the above option, it just de-syncs the route - well the track.
Why on earth would they do that?
I mean what good is a planned 450klm day that doesn't have any stops in it, viewpoints and other such places you're wanting to see. Sure you go THROUGH them, but you don't know that if you've never been there before.
Or am I missing something here?
 
Last edited:
A work around would be to save each of those stops as Favourites and number them 01; 02; 03 etc. in sequence.
I used to do that with my NAV2 device in the olden days.
 
I have the same problem as the OP, routes in plan.tomtom.com will not appear in the Go Nav app on android but do appear on my TT Rider 550 device (same email and password account details) - to be clear, syncing is on in the app settings and I'm logged in with the same account credentials. Have even tried deleteing and reinstalling the app but no joy, just more TomTom frustration to add to all of the wasted hours I have spent with various TT devices and apps over the years... any suggestions would be greatly appreciated!!
 
Also, my 'Places' DO sync from plan.tomtom.com to the Nav App, so why the routes refuse to is a mystery...
 
There is currently no solution to this problem.

Have you tried TomTom GO Ride.
 
any suggestions would be greatly appreciated!!
I'm afraid there's nothing to suggest at this time.

Reinstalling cannot solve this. The only attempt should be signing out and back into the TomTom account.
 
I'm afraid there's nothing to suggest at this time.

Reinstalling cannot solve this. The only attempt should be signing out and back into the TomTom account.
Raised ticket with support - apparently it's already a 'known issue' that has no estimated fix time so only option is to look elsewhere unfortunately...
 
There is currently no solution to this problem.

Have you tried TomTom GO Ride.
I can import GPX-file to Go Ride, but that is a real hassle...

Raised ticket with support today, according to them this is a recent issue with no estimated date for a fix.
 
Same issue as others, and have posted elsewhere. Also chatted with support and they know about it. Posting here to make following easier.....
 
I've install the beta version of the Android Go App but the results are the same. My Places sync as expected but Routes fail to do so. Logging out and back in again makes no difference
 
I have the same problem and now found after ours of trying this post. Strange thing is, that my Go 6200 (with sim) does the sync. My app and Go Premium not...
 
So far we have one iOS user responding that the issue persists. Could you please log out and back into your TomTom account and check again? We were hoping it's fixed but at least one user responds to us that it's not.

That it's affecting one product but not another for the same user makes it tricky. We see several users experiencing this.
 
I use Android, I have logged out and in, no routes, waited a while. First the mydrive app didn't show selected routes but is working now. I have made a new route via Chrome browser on my mobile and synced it, there is now a new route in my app but is has no content. (0 m).
On my Go Premium still no routes.
 

Attachments

  • Screenshot_20240717_101726_TomTom GO.jpg
    Screenshot_20240717_101726_TomTom GO.jpg
    514.1 KB · Views: 8
Last edited:
It definitely wasn't working earlier but it seems to be now. I did do a 'Clear data' on the website and recreated my routes. I don't know if it was this or a change behind the scenes that fixed it.
 
It definitely wasn't working earlier but it seems to be now. I did do a 'Clear data' on the website and recreated my routes. I don't know if it was this or a change behind the scenes that fixed it.
We did try a fix on our back-end. That's why I'm asking here to log out and back in. We continue to look into this.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,145
Messages
197,041
Members
68,197
Latest member
Gazza666

Latest Threads

Back
Top