I'm wanting to know if my TomTom 540's Traffic is up to date

Joined
Nov 25, 2010
Messages
4
I got a new TomTom 540 XXL-TM for Christmas.

I started updating the map and then received the message that I didn't have room enough or something.

So I reloaded my old map. I don't know if I have the most current map or not. When I check again I get the message: "Your map has not been updated for more than 20 weeks Unfortunately Map Share map corrections are temporarily not available".

So I don't know if I have the most current map or not?

Then I thought I would check to see if I have the current real time traffic report.

I check on "Traffic" in TomTom Home and it just says "No Items Are Available". Does that mean I have the most current traffic update or what?

Thanks
 
Last edited:
I think it is easy to confuse the Live Traffic with the IQ routes traffic information for these devices.

IQ routes uses historical traffic information I assume TT would have periodic updates for. It would be nice if a user could compare what they have on their device to what the latest/greatest updates are available. Unfortunately, unless a moderator corrects me, I don?t think we are easily able to see this across any of the downloadable objects TT provides.

The is Live traffic info that you get via the FM broadcast receiver is not anything your device needs to be updated for. You use the car charger power unit that has the receiver on it and, presto, you?re able to receive the Live traffic information.
 
OK, then maybe I'm OK.

I guess I'll find out when I go somewhere and see if it notifies me of a road that is closed.
 
I have been trying for three days to see incoming information related to Map Share. I have checked all the boxes in the TT Home: Tools>TT Map Share>Preferences and apparently there are still no updates that have come across. It says I have joined map share, but that is about it.

The bothersome part is the place where you enter for what country you want to see map changes for, No country can be selected at all ! So I am perplexed as to whether I am using this correctly.

I hope a Mod here has some insight.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,077
Messages
196,554
Members
68,084
Latest member
Jürgen Giersberg

Latest Threads

Back
Top