Help with SD card DESPERATE!

Joined
Dec 14, 2011
Messages
26
Location
Pittsburgh PA
TomTom Model(s)
GO 720 G0 730
My Go 720 no longer connects to PC. I think it is the mini USB pins on the bottom of the unit. It gets power OK, but will not mount.

Here is the issue. For my daily route I put my orders for each stop on unit as text docs. I can't do this. But, If could put my docs on an SD card then get them in the 720, I be back in business.

However, I cannot 'format' the SD with TomTom stuff. I placed docs on card, inserted, but unit sees nothing.

How can I format my card so 720 can use? If someone could send me the stuff, or upload here w/o personal data/content. I could load on my card and use? Am I making sense? Would anyone be willing to do this, or suggest another fix?
 
You shouldn't need to do any special formatting of the SD card, and as far as I know, on the Go720 you can use BOTH the internal memory and the SD card at the same time.

So there's no need to move everything onto the card.

The only thing you should need to do is put the documents into a folder on the SD card called "text" (just like the one that's on the internal memory). Are you doing that?
 
Thanks Andy_P. I added 'text' folder to SD root. Files are now recognized by 720. However, they do not open. All files stored internal open OK.

Hmmm...
 
All I can say is it SHOULD work.

The internal memory has died on my Go720 and I'm running everything off an SD card, so I can't run the full "use both at once" experiment on there.
But I just tried adding a text file to the folder on my Go940's SD card and the Go rwas able to read it just fine.

Anything odd about these text files of yours? They have to be very basic plain text.

Did you know you can also add simple .html files as well? They need to go in the same "text" folder, but I've never had a lot of luck with those, as it seems to be quite picky about what sort of html it is.

For example, I just copied one of the "Help me" files from my Go into the text folder and that opens up fine, but a sentence of text written in MS Word and then saved as .htm will produce the same symptoms as you have... the file shows in the index page, but when you open it, it's blank

Finally, is the SD card formatted to FAT32?
 
One detail - for a while (nearly a year), my 720 refused to even ask if I wanted to connect to my PC. I found that it required me to press the reset button in the bottom each time before docking it with intent to connect. Kept a paperclip on the desk. If you have not yet tried that, do that before all else.
 
Thanks all.
Before posting here, I had been trying unit reset when attempting mount on PC. Tried on Mac and Win. Also changed USB cables, and used with TT desktop dock.

Files are plain text. They are same format I have used reliably in past. The text files on unit that are still on computer, I renamed them, loaded on card. Same thing - display on 720, but will not read. All files in internal memory open OK. Content in files is plain text, copied from emails. As test, I created .txt with one sentence in notepad -null

Tried .html files -null.

I tried several SD cards, reformatting as FAT32.

It appears that anything on card shows as file, but will not open. In past I have also stored .jpegs and mp3s. I wanted to test those, but need folder names for files.

Andy_P, I like that you run a 720 from SD because of internal memory failure. I thought about this as fix, but if I loaded all TT stuff onto card, when inserted into unit, would it default to internal? Do I need to wipe internal data for SD to take over? I have one map, could that be downloaded to PC and placed on SD?

Always wondered about the reliability of mini USB. Could a pin for data be at fault?
 
If everything is on a sdhc card (application and maps, etc) then when the 720 boots up, it'll run completely off the sdhc card with no problems.

The way the unit works is that if it detects the application on the sdhc card, it boots there first.
 
Thanks, I guess that makes sense, but since I don't have unit backed up on PC. How can I duplicate file system on SD, as it would be on unit? I have no clue what needs to be on SD.

Can application, maps, etc., be d/l from TomTom to PC then loaded onto card?

Could you show me the file structure in reply? -thx
 
I am new to forum, and have not properly searched for fixes in other discussions. If info is elsewhere, please point, suggest search params.

This is my first post, and am quite happy about the replies -good guys all.
 
Be clear, we are talking about a sdhc card here, not a sd card.

Anyway, if you put the sdhc card in a card reader and start Home (withOUT the tomtom unit connected to the computer), it'll think the sdhc card IS the tomtom unit connected and offer to install the application on the card. Allow it to do so.

Then you can copy the specific map folders from the internal to the sdhc card using Explorer.
 
@ dhn... except that he can't access the internal!:fish:

carson-jc.... There's nowhere we can point you to where you can get everything that was on the internal memory in a single place, it will need some fiddling around to find most stuff.

If you can get a set of operating system files onto the card, then TT Home will let you download a voice or two to get you started.
TBH I didn't think Home will recognise an SD card in a card reader UNTIL you have those system files on it, but I might well be wrong.
Give it a try, and if you have no luck we can give you a manual download link for the software itself.

The main problem is your map. If you haven't ever bought one and downloaded it via your PC, then it will only exist on the machine, and as you probably know, each map is locked to a specific hardware device, so if we can't get it off the internal memory, you'll have to buy a new one.

Maybe we should also spend a little time seeing if we can get the PC link working again, before we spend too much time on file recovery?
 
But didn't he say files open properly on internal??

Thanks Andy_P. I added 'text' folder to SD root. Files are now recognized by 720. However, they do not open. All files stored internal open OK.
 
Yes, but what he means is that text files that he'd previously stored on the internal memory can be opened by the TomTom's document reader.
He still can't access the internal mem. on his PC.
 
Home does not recognize newly formatted memory card (SDHC), as TT device.
Home 'help' says to format card FAT32, insert to unit, boot -then take out card, stating that the card has then been 'initialized.' Tried this, but didn't help with Home 'recognition.'

What do you mean by, "If you can get a set of operating system files onto the card?" Like install an iteration of Linux, perhaps? The manual download link, sounds promising.

Yes, my map is purchased, and up to date. I thought my TT website login, or home would provide access for additional d/l. But, if it is hardware coded to unit, hmmm. I may have an older map on backup media somewhere around here... LOL - I looked, but will look again.

I will continue PC recognition of unit, but I have been quite a l-o-n-g way down that road. That's really the issue. Really. I still think the mini USB is fault.

Thanks for sticking with me on this one. You have brightened my day.
 
Thanks,
Opened .cab in explorer, copied to memory card. Inserted into unit, booted as normal from internal with internal map.

Inserted sdhc into PC, created 'text' folder, loaded two .txt files. Inserted sdhc into unit, and presto! it reads the files. This is what I set out to accomplish. A big thanks.

So, that leaves me with a unit not recognized by PC. A card that I can load .txt files from PC and use in unit. That is great, and maybe we should stop here. But, if the memory card would do it all, then I could have a fully functioning unit.

Also, Home did not recognize memory card in card reader.
 
Thanks,
Opened .cab in explorer, copied to memory card. Inserted into unit, booted as normal from internal with internal map.

Did you extract the contents of the .cab archive? (We should have made that clear).
Unless it's changed on newer versions of Windows, WinExplorer can't do that on it's own.
You need something like WinRAR to extract the contents of the .cab.

There's a WHOLE load of extra 'gumph' in the download link you were given, but once you've got the proper files on the card, it should have individual files such as:

ttsystem
system
data.chk
etc.
etc.
 
Win7 OS - 'Windows Explorer' does extract .cab as 394 items, including ttsystem, system, data.ck, etc. Like you say, a lot of 'gumph.'

But, unit did not boot from memory card. The boot loading graphics show icon of unit, progress bar at bottom, and icon of internal drive only. In the past, there would also be icon of sdhc memory card. Not there now.

Home does not recognize memory card as device in card reader at PC.
 
Are you certain that the extraction was successfully made to appropriate folders on the SD card? Take a look with your card reader and assure that there aren't just a bunch of files in the root, but that folders were created and filled as well.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,017
Messages
196,002
Members
67,997
Latest member
Top_ba

Latest Threads

Back
Top