Windows 8.1 computer does not recognize device on My Drive

Joined
Aug 2, 2015
Messages
3
Country
<img src="/styles/default/custom/flags/us.png" alt="United States" /> United States
TomTom Model(s)
GO 60S
Purchased new GO 60S and downloaded My Drive software. Following directions, computer does not see the Tom Tom correctly and therefore will not link.
 
I am using the cable that came with the device on a usb port on the computer itself. Not a hub. The TT appears in the device manager as "Other devices" (not a Network adapter)Tom Tom GO60 with no driver installed and Windows in unable to reinstall the driver C:\Program Files\MyDrive Connect\Driver\INF. Will Drive Connect not work on USB 3?
 
When you plug in the device, do you hear the PC sound made when an external adapter is connected, disconnected?
I won't vouch for it but there have been some who had problems with USB 3.
If you do not have a PC with USB 2 or lesser to test the connected sound could you try it at a friend.
This has nothing to do with MyDrive, just to see if your device is recognised by a PC.
 
I do get the computer sound. I am currently trying to borrow a laptop for testing.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,081
Messages
196,586
Members
68,091
Latest member
ziviani

Latest Threads

Back
Top