TT740 Live and Live Services

Joined
Apr 18, 2009
Messages
48
Location
Florida
TomTom Model(s)
TomTom Go 740
I have a TomTom 740 live and just subscribed to live services and am kind of disappointed in the way it is working.....I bought my 740 back when they were first introduced in the US and tried out the free live services that they furnished when buying a new TT740...seeing how unreliable it was i decided not to subscribe at that time.....Ive been using my TT740 since then with no live service....then when they brought out the HD traffic in the US I thought I would try it again with the hopes that I wasnt wasting my money....Well I have been using it for about 2 weeks now and find that it is still slow to connect to live services and sometimes have to turn off the TT and then turn it back on to get it to load. Then when it does an update after it does load there is a long delay connecting to the service again....in fact just today I drove about 20 miles waiting for a connect. I just think that when you turn on your TT and it tries to connect it should connect......I mean if you went home and turned on your lights in your house and they didnt come on for about 10 minutes or so you would be pretty upset.....I really like the features that the TT has and that is why I bought one in the first place but it is really disturbing that a company as big as TomTom cant get their act together and get things right. I look in these forum just about every day and just about every day someone, somewhere is having problems with their TomTom's.....Surely they have some kind of quality control in place that they can get their act together and get things right. As of right now if I ever buy another gps unit Im afraid that I will have to go to another manufacturer even though I do like the features of the TomTom. Sorry about all the raving but I have just about had it with putting out money for products that arent worth a crap or they dont work as advertised. By the way I am running a TomTom 740 Live with the latest application 9.58 and the latest maps version 8.70 with a 4 gig card. Thanks for listening....
 
App 9.058 is a terrible application, rushed out to to make a sales deadline with tons of known LIVE connection and crash-inducing bugs.

Try app 8.312, it is much much more stable, and makes the 740 a very good device. See here for instructions.
 
Thank you for the reply and help.....Ill give it a try first thing in the morning and see how it goes. Again, thanks for the help.
 
I followed your instructions to the letter.....got done and rebooted the TT.....after the reboot i went in to make sure that I had the version of app that you recommened but is still showing 9.58.....I copied the contents of that zip file to the TT like you said......any suggestions????? I have everything loaded on my external card and that is where I naturally copied all files to. Thanks again for all the help.....
 
If you run everything on the SD card, then make sure the internal is 100% empty, no files at all. See if that helps.

Also, beware that app 8.312 will not retain your favorites during a map update, and will probably also lose them in this map-download process.
 
I went through the process of recopying like you instructed and this time everything went well....got the older app installed and am setting everything up....Your right things do seem to work faster and better....just lost a few of the new goodies that were in app 9.58....but that is no biggie. Im just happy things are working like they should. I just hope that TT gets another update to the app out that works like its supposed to....so until they do im going to just stick to the one you helped me get installed. Thanks for all the time and effort all of the mod's put in here helping people like us through our problems...
 
Another quirk......This morning I turned on my TT and everything works great as far as the GPS is concerned....its the Live Services that dont work....Im getting the famous little yellow triangle on the right side of the screen....I go to "my account" and get the red screen that says that I dont have a subscription or that my subscription as expired. If i click on the bars that show the satellite connection and go to the network page it shows me connected to the live services.....and all four of the fields on that page are filled in with the required info. Did I miss something here to make this work with the older app version???? If I try and use the google search or the weather, it pops up a red screen that says there is an error on the server.....
 
That happenned to me once. Sometimes the downgrade confuses the 740. The following helped me:
-change your email address in Tomtom account settings on the Tomtom.com website.
-Close Home, reopen it, and use the new email address and old password to login.
-Run operate my go and see if you get LIVE traffic to work im the emulator. Then disconnect with the blue button in HOME, and see if the traffic starts working on the Tomtom.
 
App 9.058 is a terrible application, rushed out to to make a sales deadline with tons of known LIVE connection and crash-inducing bugs.
Actually, the 740 was originally shipped (rushed out) with 9.054. After what I heard from users on 9.058, I've been avoiding the update all this time, and rarely have Live issues of any kind. I often wonder if they 'broke' it with whatever fixes they were trying to include in 9.058. Do we have a copy of 9.054 in captivity for download somewhere? On a lark, I tried http://download.tomtom.com/sweet/navcore/9.054.go540-go740_navcore-GO.cab but that didn't get me a good result.
 
i was wondering the same thing....i had 9.58 on my TT and was wondering if the previous version would be any better....i dont think i had these problems till I updated to the 9.58 release
 
i would love to get hold of app ver 9.54 and put back on my TT....this 9.58 really sucks.....I just cant imagine how TT can put out a piece of crap like this.....with version 9.58 it will boot up and let you set a route....and then eventually it will find the live services.....and now, i have seen my TT sit there and freeze up after connecting to live services and then eventually does a reboot on its own.....guess its time to go out shopping for a new GPS and get the hell away from TT......sure wouldnt waste any more money with them thats for sure....and i send my apologies to everyone in the forum for my ranting.....but this is just frustrating when you pay for something and not get it....and the sad part about it is, the GPS itself is a great unit....its the software that they supposedly send us to update with.....I think TT needs to get some experienced people in there that can program and trouble shoot to put out a good product....I never had any of these issues with the original app that was on the unit.....all my problems started with each and every update that they put out things got a little worse each time......oh well enough ranting.....TT sure doesnt seem care apparently that we are having problems like this.....
 
Last edited:
Excellent. You have that link now, Barnwellm?

Back up your unit to your PC (good idea no matter what).

Extract the contents of the cab file (just like if it were a zip or rar file), maintaining all of the path information.

Be advised that Home may well try to force 9.058 on you again, but there's a very simple workaround for that in this thread: https://www.tomtomforums.com/genera...5167-cannot-de-select-application-update.html
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,145
Messages
197,047
Members
68,198
Latest member
Bob Jack

Latest Threads

Back
Top