Slow GPS fix with ipod touch with car kit

Joined
Jan 5, 2011
Messages
1
Hi
Maybe somebody can help me.
My car kit finds very slowly the GPS position for TomTom Navigation software. It may take up to 15-20 minutes!
Once it finds, it works perfectly. If I keep the cradle connected to power for the night, next morning starts to work immediately. If not, it starts with the above mentioned long search again....
The strange thing is that the free TomTom Car Kit Tool App finds almost immediately GPS fix, it shows the satellites channels and the coordinates as I am moving around, but when I quit it and start the TomTom navigation software, it does not get the positions. The same happens with other navigations softwares. I installed a free App called GPS-Status and this also does not get the positions.
Is it possible that the Car Kit Tool App is more sensitive? Uses other approach to communicate with the GPS chip, maybe directly and the TomTom navigation software uses Ipod system functions?
Somebody has any idea?
I also read somewhere that TomTom has a service called QuickGpsFix. Can this be used with the car kit/ipod?

Thanks
Balint
 
Hi I have exactly the same problem. I also have an IPhone 4 which works perfectly using the TomTom IPhone car kit and TT 1.6. Using the IPod 4 in the TT Car Kit is a nightmare as you have described. I purchased a Bluetooth GPS receiver from GNS. Google GNS 5870 MFI. I tested the Bluethooth receiver with an IPad that I have and TomTom software version 1.6 and it worked perfectly. I also tested with my IPhone 4 and it also worked perfectly. But when I pair it with my IPod 4 and TomTom 1.6 there is a problem. I get the message 'Connect To GPS' but I can still navigate, so it appears the TomTom software sees the Bluethooth GPS signal. My wife took the IPod and Bluetooth receiver to work today, she reports back saying 'Poor GPS reception' which is just crazy! The units are paired and the 'Green Light' on the Bluetooth is solid green indicating a valid GPS siginal.
I came across this last night Issue 84 - btstack - TomTom reports "Connect to GPS" on new iPod Touch 4G - A Portable User-Space Bluetooth Stack - Google Project Hosting
Which is explains the problem I am now having, but the fix here requires the IPod to be jailbroken. In my mind TT 1.6 and IPod just don't work together, but no one will ever admit to that...
Cheers
Mark
 
Ditto

Latest update of app yet when I turn it on it never locates the satellites. Half the time it will start tracking and then suddenly tells me to "Connect GPS" which is of course already connected. Not real useful as it is now.

iPod Touch 4th Gen while wearing jacket and with pad to dock port to fill gap.

BR :confused:
 
Hi, anyone find the solution for this problem? I'm having the same issue with my TomTom Car Kit for iPod touch. Takes forever to get the fix even on CarKit tool app.

I don't find any fix on internet and this issue is rendering my unit near the unusable! I can't wait 20 minutes to start drive.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
28,976
Messages
195,671
Members
67,958
Latest member
abowen

Latest Threads

Back
Top