MyDrive Connect slow and erratic on MacBook?

Discussion in 'General TomTom Discussion' started by Brims, Jun 2, 2016.

  1. Brims

    Brims

    Joined:
    Jun 1, 2016
    Messages:
    5
    Likes Received:
    0
    TomTom Model(s):
    GO 5100
    Patience please Guys, I'm new here!

    I've just moved up to a GO 5100 after my old TomTom device (over 10 years old) screen failed.

    I'm using a MacBook Pro with OSX El Capitan ver. 10.11.5 on a modest, but adequate for most purposes, BT Broadband.
    and
    MyDrive Connect ver. 4.1.0.2723

    I'm finding that MyDrive Connect loads amazingly slowly if at all.
    As often as not when it does load and invite login then as soon as I start to type password I get the whirling beach ball which can go on for minutes. Then when eventually it decides to allow me to type I get "login timed out" and more beach ball when I start typing again. Often the next thing is a login window without panels for email or password - only a create account option.

    Every so often it does actually connect and appears to be working OK - showing MyPlaces etc correctly, and has me logged in OK

    Any suggestions?
    or is this "normal" for TomTom these days?

    Brims in Scotland
     
    Brims, Jun 2, 2016
    #1
    1. Advertisements

  2. Brims

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,975
    Likes Received:
    441
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    dhn, Jun 2, 2016
    #2
    1. Advertisements

  3. Brims

    Brims

    Joined:
    Jun 1, 2016
    Messages:
    5
    Likes Received:
    0
    TomTom Model(s):
    GO 5100
    I have tried uninstalling and reinstalling MDC - makes no difference still doesn't work!
    Very slow to load.
    Then when I click in box to enter e-mail address, I get the whirling beach ball i.e. exactly as before!

    What next?
     
    Brims, Jun 3, 2016
    #3
  4. Brims

    Brims

    Joined:
    Jun 1, 2016
    Messages:
    5
    Likes Received:
    0
    TomTom Model(s):
    GO 5100
    Actually, it's even worse than before!
    once MyDrive Connect actually loads and settles down, whenever I click anywhere I get the whirling beach ball.
    After some minutes beach ball stops and log in window looks good but any attempt to so anything produces the beach ball again. Wont close or anything.
    The only way out is two finger tap on icon in dock and select "force quit".
     
    Brims, Jun 3, 2016
    #4
  5. Brims

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,975
    Likes Received:
    441
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Then call support............
     
    dhn, Jun 3, 2016
    #5
  6. Brims

    Brims

    Joined:
    Jun 1, 2016
    Messages:
    5
    Likes Received:
    0
    TomTom Model(s):
    GO 5100
    Thanks dhn,

    I was actually waiting for a response (by e-mail) from support and got one from Afnan.
    He sent me an e-mail which had a longish and comprehensive strategy to overcome this.
    I had to create a new user on my MacBook (which with some trepidation I did - I'm no computer geek!) and then download and install MyDrive Connect .
    Happily it all seems to have worked and I can open it from the original user now that it's installed!

    Brims
     
    Brims, Jun 3, 2016
    #6
  7. Brims

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,975
    Likes Received:
    441
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Thanks for the feedback
     
    dhn, Jun 3, 2016
    #7
  8. Brims

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,814
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    If you can post a copy of the email, I'd like to see that -- especially any explanation that provides a clue as to why a new user had to be created in order for MDC to operate properly. That's not something we see here, and it would be good to understand the root problem.
     
    canderson, Jun 4, 2016
    #8
  9. Brims

    Brims

    Joined:
    Jun 1, 2016
    Messages:
    5
    Likes Received:
    0
    TomTom Model(s):
    GO 5100
    OK canderson here you go:
    startquote:
    Alasdair, please refer the steps mentioned below :-

    1. Click on MyTomTom Support Application/MyDrive Connect in the Apple menu.
    2. Click on Exit.
    3. If you cannot find the application in the Apple menu, check via the Activity Monitor. To find the Activity Monitor do the following:
    Make sure Finder is selected.
    In the top Apple menu, click GO.
    Click on Utilities.
    Click on Activity Monitor.

    4. Go to Finder.
    In the top Apple menu click GO.
    Click on Applications.
    Drag and drop MyDriveConnect.app into the trash.

    5. Go to the Finder.
    In the Apple menu click GO.
    Click on Library (if you cannot see it on the menu, press Alt on the keyboard).

    6. In the Library, go to the folder Application Support and delete the TomTom folder.

    7. In the Library, go to the folder Caches.
    Delete the folder com.tomtom.mytomtomsa (if available).
    Delete the folder com.tomtom.mydriveconnect.

    8. In the Library, go to the folder Preferences.
    Delete com.tomtomsa.plist (if available).
    Delete com.tomtomsa.plist.lockfile (if available.
    Delete com.mydriveconnect.plist.
    Delete com.mydriveconnect.plist.lockfile (if available).

    9. Download MyDriveConnect Support application from the website: http://www.tomtom.com/getstarted.
    Double click on the file.
    Double click again on the box to open the installation wizar d.

    10. Once MyDrive has been installed, test by connecting a device.

    11. If the above steps don't work, uninstall MyDriveConnect as above, but before re-installing MyDriveConnect, create a new user account.
    1. From the Apple menu, select System Preferences...
    2. From the View menu, select Users & Groups (Mac OS X 10.7 or later) or Accounts (Mac OS X 10.6 or earlier).
    Note: If it's locked, click the padlock in the bottom left corner of the window, and then authenticate as an administrator.
    3. Under the list of user accounts, click the plus sign.
    4. From the menu next to New Account:, select Administrator.
    5. In the Full Name: field, enter the new user's name.
    6. In the Account Name: or Short Name: field, enter a username you wish to assign to the user.
    7. Install MyDriveConnect as per step 9.

    I trust the information mentioned above will be helpful to get you a resolution. Please feel free to update me regarding the issue and I will be happy to assist you further.
    endquote.

    I had to go through all the steps above, but, it worked (not all the files mentioned in 7&8 were found!).
    I still have the new user on my MacBook, but provided "new user" isn't using MyDrive Connect, I can log in with "original user", open MDC and all seems to work OK
    I have no explanation but am pleased to have a functioning copy.

    Hope this helps - like to hear your views.

    Brims
     
    Brims, Jun 4, 2016
    #9
  10. Brims

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,814
    Likes Received:
    177
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Interesting. After the uninstall, they evidently still feel there will be remnants from the original app in the original user's sandbox that they can't tell you how to remove, and might have negative impact on the situation -- so they have you install as a new user such that the offending data is never looked at by the newly installed app. Sounds like a pretty lame workaround, but if it works, at least we have that in hand as an option.
     
    canderson, Jun 5, 2016
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.