Problems with a WebFleet Pro 7250

Joined
Jan 4, 2024
Messages
4
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Pro 7250
Hello all - I'm hoping someone here can help me resurrect an old 7250.

I have a WebFleet 7250 which was playing up. I connected it to MyDrive connect and it immediately said it was restoring my device. It got to 100% and the 7250 rebooted but now it's stuck in a loop where it says there are no maps available, you tap OK, it tries to load (Icons appear down the left of the screen) then displays the maps error again. It doesn't give you any chance to access the menu at all.
I have spoken to WebFleet and, of course, they say it's broken and I should buy an shiny new one 😒. I have tried installing updates via an SD card but it doesn't even acknowledge it's there.
In the past I managed to resurrect an old TomTom Go (or was it a One 🤔) by direct access to the internal memory via a laptop but this doesn't seem to allow that kind of connection - is there anyway to bring this thing back from the brink of death or should I admit defeat?

Thanks in advance.
 
Hi

If the software was restored correctly, the device will boot and operate normally.

Updating using a microSD card
Updating PRO 5250/7250 by microSD card does not require an Internet connection during the update process. However, it is necessary to download the update as a zip file via Mobile Device Manager, store the file on a computer and extract its contents to an empty, formatted microSD card (minimum capacity 8 GB/maximum capacity 32 GB).

If the software was restored correctly, the device will boot and operate normally.



Or contact customer service https://portals.webfleet.com/s/contactsupport?language=en_GB
 
Hi

If the software was restored correctly, the device will boot and operate normally.

Updating using a microSD card
Updating PRO 5250/7250 by microSD card does not require an Internet connection during the update process. However, it is necessary to download the update as a zip file via Mobile Device Manager, store the file on a computer and extract its contents to an empty, formatted microSD card (minimum capacity 8 GB/maximum capacity 32 GB).

If the software was restored correctly, the device will boot and operate normally.



Or contact customer service https://portals.webfleet.com/s/contactsupport?language=en_GB
Thanks Willy.

There must be a bigger problem with this unit. I have tried the MyDrive Connect restore method 3 or 4 times by long pressing the power button then pressing 3 times to enter recovery mode. Every time it got to 100%. The TomTom rebooted but still displayed the 'updating' screen. The first time, I left it overnight (from about 5:30pm until about 7am) but it was still on the 'updating' screen and the laptop showed no signs it was doing anything, so I disconnected (did I wait long enough?).
I also tried the SD card method, 99% sure I followed the same sequence you posted (I've slept since then 😄). It didn't even detect the card, so nothing happened. I am downloading it again to give it another try but I'm not holding my breath.
I contacted customer service at WebFleet and they said its too old to have full support and I should upgrade to a newer device. Which they are more than happy to help me with.
Thanks for your guidance, I'll try the SD card thing again. If that don't work, maybe the MyDrive thing (and leave it for longer?). Failing that, it will have to go to the final destination in the sky (if it can find it's way with no maps 🤣).

Many thanks 👍
 
@Willy875 When I copy the files to the SD, should I copy the folder it is extracted to (TomTom_PRO_x250_EU-SW_v15.523-MAP_eu_v1120-default-1701854769073) to the root, or should the root folder be the ttt folder within that?

Cheers
 
That's what I followed last time, it doesn't actually say. I tried both, doesn't recognise either.
I'm trying the MyDrive way again, I forgot to mention that after the 100% complete, when the TomTom has the 'Updating' message, MyDrive has an error on screen too. It says 'Unknown Navcore Version'. I think it's time to chuck it in the bin 😔
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Staff online

Members online

Latest resources

Forum statistics

Threads
28,866
Messages
194,748
Members
67,813
Latest member
Cumbrian

Latest Threads

Back
Top