No maps after update to Go910

Joined
Dec 28, 2012
Messages
1
Location
leicester, uk
TomTom Model(s)
go 910
Hi, did a software update on my go 910, it then stated no maps found, reloaded through tomtom home and recovered most of it, unfortunately i did not do a back up, so not sure if it was fully recovered, I know the usa maps are not on my device, its on totmtom home but very wary of reloading it, is it possible to get a copy of maps to reload
 
Sorry, without a backup, you can't get the maps. If the USA map shows as being on the device, try Manage maps-->switch maps.
 
I did a softwear update on my old GO910 and there was an update of Western Europa map, but when it al was done it tells me that i cant use the update ? and when i check it has removed my old map and there is no Europa map in it anymore., i did have a back up but on an old laptop that collapsed. Now i only have maps of US , Guam , and canary island showing in the meny, but if i go into the disk it shows Western Europa, but i cant get it up on the 910 meny to choose. ?? will a reset bring it back, ?
 
will a reset bring it back, ?

Doubtful, but you have nothing to lose by trying.

I did a softwear update on my old GO910 and there was an update of Western Europa map
Could you say exactly what happened here?

It would be very unusual for you do do a software update and to get offered a map as well, just like that.
Normally for a model of the age of yours the best you could expect is an offer to BUY a new map at a discounted price.

If you did buy a new map, then it will be available to download again. You'll need to remove the non-working map from the device and also from TT Home's download cache folder on your PC, before it will be offered again.
If this is your situation, let us know and we can give more precise instructions for that.

Too late for you.... but this does emphasise how vital it is to keep good backups and to MAKE a backup before doing ANY major updates.
 
Well i did conect it and what came up was a long list of small updates + Western europa it was 2253mb (or close to that) and i started to load, afther a while it stopped, and i had to restart loading many times befor it all went in. then when all was done, there was a line in red. saying that this map(seamless) will not work on this unit ?? why did it offer it to be downloaded if if not was for this 910. ?? i did try to do a back up but it just came up with some failure messages. then when i wanted to run it again, the Westen europa was gone, but when open up the files it looks like it is still there. i removed the file, and did load one more time, due to Home page telling me to. telling me that i had to down load this Wester Europa, i did but still not working. i just got home from work, so i will try again a bit later.. also restart, and se what happens.
 
Again, I can't understand why it would offer a new map without you buying one, but the only people who could explain that to you are TT customer services.
Hvis du har en bestillingsforespørsel eller er interessert i å oppgradere til et av de nyeste TomTom-produktene, kan du ringe salgsavdelingen på 81556710.

If you want to try downloading the map again, you'll need to delete the already downloaded version from the cache in:
C:\Documents and Settings\username\My Documents\TomTom\HOME\Downloads\complete\map (if Windows XP) or
C:\Users\username\Documents\TomTom\HOME\Downloads\complete\map (if Windows 7/8/VISTA)
 
i do se that i did this from the MY Tomtom site ? is this wrong, as i have been reading about there is an older Home 2 site ?
So i am now trying to find that one.
Is it Home or My Tomtom for this unit ?
OK, found it. it is Home for this one, i used My tom-tom yesterday.
What a bugger........
i even updateted the ONE 3RD also from this site, and i see now that wrong, but that one runs fine :)
 
For very old models and software you may need to begin with Home v1 - update the software as far as possible with that, and only then start using Home v2 to update further.

Both Home v1 and Home v2 are available from this webpage:
http://www.tomtom.com/services/service.php?id=16&tab=87

(The link for Home v1.6 is underneath the main blue buttons for Home v2)
 
to late i have downloaded V 2.9 and connected, will se how it goes.
i am on now and 1 updates come up
Western & Central Europa 2251mb
nothing else...... do i download yes, ?
 
it came up at once , with that it is downloaded, now it is installing on the hard disk
 
it it saying al OK: but when i look for it on the Change map it is not there,
will try to check the file......
 
when i go into the box Updating, there is tha map again, and when i open up the map on "Read more" it is saying in RED this element has to be downloaded. Versjon 855.3046
but why is it not showing on my 910, when its done. ?
yesteday there was a message that i needed to activate it ? but that one has not been here now ? and how do i activate it ?

Doing it one more time. it is now installing to hard disk (copying)
 
i give up......... from now on i can only use it when i am in USA on holidays
lets hope the new VIA is working fine.
 
if It appeared at once, then that means you are not downloading a fresh copy, but it it reinstalling the copy it saved to your PC last time.

If the problem is with that download then you'll have the same problem again.

If you want to ensure you download a FRESH copy from the TomTom servers, then you have to delete the old one from the cache, see post no.6 for the location on your PC hard drive.

Once it is installed you do realise you have to select that map in "Switch map" don't you?
 
Yes i did that, but it does not come up with the map,
When you go to select map, in Swich map it only shows USA, GUAM and Canary island. No where can i find Western Europa. :)
and when i try to use Usa map it starts up in Florida where i did go on a holliday in 2008.:)
i also tryed to put in the coord, manualy but it will not take the input, it just jumps back to Florida.
i also empty the cache, but still the same.
but on the files in the 910 it shows files for the map loaded 2007.
i will se if i have time tonigth and try once more delete the old file in the 910 and try to download again. ? or what ?
--------
i will , when i get time, do backup of all "nice to have stuff" and leave it on a smal harddisk. and down deep in the office desk.
(then when i need it , i most likely have forgotten that i did it :D
 
Not sure if you did this, but the cache needs to be emptied before you try to re-download.

Also, just had another thought... new maps will only be seen if your software is also up to date. What software version are you running?
See here for details on finding your version numbers:
How to find the version numbers of your maps and software
 
Yes Cache is empty.
and i went into the file and removed the map from the unit. also.
and is now downloading once more, there also came up a GPS fix.
it is now installing on the hardisk, 2251.7mb. so it takes some time.
 
Now the new map over Europa is in the 910 file, but it does not come up when i look for it in Change maps menu ?
is there a activating file missing ? or can i start it from the file ? witch file does rund the map ?
 
Connect your 910 to Home. Go to Manage my Device (purple folder, 2nd page), items on device-->maps. What does it show if you click the '+' symbol (if it is there).

What about the 'Items on computer-->maps, what does it show???
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,145
Messages
197,041
Members
68,197
Latest member
Gazza666

Latest Threads

Back
Top