Continuous restoring your device loop tomtom 610


Joined
Nov 24, 2019
Messages
3
TomTom Model(s)
610
Hi,

I have a TomTom 610 and I think the software on it is corrupted.

When it boots up, the white line stops about half way across.
I followed the instructions to reset my device.

I get it into restoring your device and it creeps up to 100%.
Tries to boot up.
Fails
Eventually the spinning doughnut starts again and the restoring your device process begins again.
And again... and so on.
It really likes that restoring your device process.

I have a micro sd card in the device and it was working ok until I tried to install a map update last week.
As part of that process I upgraded mydrive connect to v 4.2.6.3888 and it seems something went wrong.

Didn't have enough time to work out what was going on so I used my smartphone.
Waze worked pretty well actually.

Any ideas?
 
Ad

Advertisements

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,252
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Try restoring without the SD card installed and see if that makes a difference.
 
Joined
Nov 24, 2019
Messages
3
TomTom Model(s)
610
That's a great idea, thanks.
Definitely an improvement.
Got much further and looks hopeful.
Currently installing one version upgrade after another.
 

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,252
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
You'll probably want to reformat that uSD card on your PC before you install it again.
 
Ad

Advertisements

Joined
Nov 24, 2019
Messages
3
TomTom Model(s)
610
Took me a while to get around to finalising this....
I removed the micro sd card.
On investigating the options I realised I was trying to install maps for all of Europe.
As it turns out I don't need all Europe and will mainly just be driving round the UK.
When I chose a smaller area I found I could easily fit that on the device with no micro sd card.
Re-installed the maps and it seems to be working ok now.

Thanks for the help.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top