Cannot checkout in TomTom Home -- serial number issue?

Joined
May 31, 2010
Messages
3
Location
Cambridge, UK
TomTom Model(s)
Go 520
Hi folks,

I have a TomTom Go 520, and I've not updated the maps for a little while. I thought I'd take the plunge and get the new United Kingdom map, along with the one-year map update service. However, when I come to checkout in TomTom Home, I get a generic error message. Digging into the details, it appears that the service is choking on my device's serial number: I get it's "error 104" with the text "The following information is incorrect:" and then the serial number of my device, which is being passed to the server as the argument "info.args.deviceSerial".

It's all a little bit mysterious. I've tried reinstalling Home (and doing so on a separate machine) as well as resetting the Go 520 itself, just to rule out any oddities there. The problem remains though -- it appears that the payment server doesn't like my serial number.

Any ideas? I've e-mailed TomTom Support, too but, from other people's experiences posted online, I'm not holding out a huge amount of hope for help from there!

Stuart.
 
Well, for starters, the current map is 845 BUT an 850 is overdue. By TT's normal map release, it should have been out a week or so ago. So, I'd suggest that you wait a few days till it does get released and then try for the map updating then.

That said, TomTom's servers are often flakey, whether for software distribution or their payment servers. I'd call support at:

08451610009
Monday - Friday: 9:00 a.m. to 6:30 p.m. GMT

to let them assist. But, as I said, try waiting a few days..............
 
Now that's a useful tip -- thank you, dhn! I'll watch for version 850 to be released, and will then try again and/or call TomTom support, if they have e-mailed back with a solution in the meantime...

Thanks!
Stuart.
 
Just to follow up, I appear to have wronged TomTom Support: they were absolutely fantastic. This was in fact a known issue with the Go 520, with map version 845. They offered to let me buy the standalone map, and then they would add the one year subscription for me. In the end, I instead waited until 850 was released, as dhn astutely suggested, and the problem was fixed in the new map version in any case.

Thanks for the help!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
28,871
Messages
194,804
Members
67,822
Latest member
LukeDavis

Latest Threads

Back
Top