Yet another battery question - GO 720

Joined
Jul 25, 2010
Messages
2
Location
Australia
TomTom Model(s)
GO720
When charging, is the word CHARGING supposed to be under the battery symbol? I have the green light on (USB, dock or car) but battery does not charge.

I have a new one which I will install BUT could there be a problem with the USB connection on the unit. Screen shows that input is 5V, but no held charge.

Battery dead??????

Steve
 
I have a Go720 in front of me.

As far as I remember the battery symbol only appears when you are running on battery power and the battery is running low.
But with it plugged into external power, the battery symbol disappears.

So I don't quite understand your question... I don't think I've ever seen the word "charging" appear below the battery symbol, but I don't think I've ever seen the battery symbol itself while charging either.

But I could be wrong.... It's fully charged at the moment so I'll leave it powered on for a couple of hours to run it down and check again.

More generally, if you haven't changed the battery yet, it's almost certainly dying by now on a machine of that age, so I would assume that's the problem.

If there was a problem with the USB connector then you wouldn't get the green light and it wouldn't work on external power.

I would go ahead and change it, but be extremely careful when prising the old battery off the circuit board. Use some sort of solvent to soften the glue, and don't try to lever it up in case you damage a tiny component, (it happens a lot).
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
28,866
Messages
194,746
Members
67,813
Latest member
Cumbrian

Latest Threads

Back
Top