Voice guidance has stopped working on my GO Premium X

Joined
May 28, 2023
Messages
3
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
CO Premium X
The en-route voice guidance suddenly stopped working on my Go Premium which is just 2 years old.. However the initial time of arrival announcemnt is still working and all the voices available in voice selection respond with the sample message when selected. I assume it is a software issue but can anyone tell me how to fix it.
I have tried everything I can think of bar a factory reset which I don't think would fix it, as well as wiping a load of routes I have set up for an upcoming road trip.
 
Hi there @Gatineau 13 -

Have you also checked to make sure that Voice Instructions (tap the 4 dots bottom left map screen icon) then the second from the bottom right icon doesn’t have a line crossed through it like in the photo? Sometimes it can be accidentally tapped on. If it’s still got the line crossed through, you would still get an arrival time but no route instructions.
IMG_1487.jpeg
 
Thank you for these replies.
My routes were planned and stored on my tomtom device which is set to Sync. These are not updated to Mydrive and I cannot find a way of doing so.
The voice instructions were the first thing I checked and that the volume slide was not set to minimum.
 
If your routes do not sync with Mydrive, you are not logged into your account or there is an error typing your login ID.
 
My device tells me it is connected to Mydrive with the correct email address and it is set up to sync.
I have created a place and a route in Mydrive and they have synced to my device. Indeed Mydrive gives me the option to choose to sync the route with my devices when saving it.
However, I then created a new place and new route on my device and saved them but that did not cause them sync to Mydrive (though the rest of my places have been synced). The blurb in the Mydrive screen on the device tells me that "destinations, place lists and favourites are automatically synced with Mydrive" no mention of routes.
 
My TomTom premium go doesn’t make any sound at all, even when starting up you no longer get the chime. I’ve checked all the settings (volume & voice etc). It does this randomly then for no reason will work normally for a while then stop again. Tried resetting, still doing it.
 
My TomTom premium go doesn’t make any sound at all, even when starting up you no longer get the chime. I’ve checked all the settings (volume & voice etc). It does this randomly then for no reason will work normally for a while then stop again. Tried resetting, still doing it.
Did you perform a factory reset?
 
Yes, didn’t do anything
Just curious --

Did you notice this post photo, above? Notice how there's a ' / ' through the 'speaking person' (second bubble from the right at the bottom). That would indicate that the voice instructions are turned off. Make sure yours hasn't got into that state. Sometimes it happens, especially when running the volume slider far right.

IMG_1487.jpeg
 
Just curious --

Did you notice this post photo, above? Notice how there's a ' / ' through the 'speaking person' (second bubble from the right at the bottom). That would indicate that the voice instructions are turned off. Make sure yours hasn't got into that state. Sometimes it happens, especially when running the volume slider far right.

View attachment 6066
As I said, I checked all the settings, and there is no line through the voice. I even tried turning the voice commands off and on again, but thst didn’t work. The volume is at 75%, so that isn’t all the way down. Also, as I said, it’s not just voice commands, i get no sound at all, ie no alerts for speed cameras etc. It will suddenly start working for no reason, then stop for no reason, unfortunately, it doesn’t;t make any sound more often than it does.
 
Did you manage to resolve this? I have the same exact problem. My TomTom start 52 device was speaking street names earlier but it stopped working now. It announces the arrival time at the beginning though.
 
Did you manage to resolve this? I have the same exact problem. My TomTom start 52 device was speaking street names earlier but it stopped working now. It announces the arrival time at the beginning though.
If everything is activated correctly

This is because you have not selected a synthetic voice, select Malcolm or Serena.
 
If everything is activated correctly

This is because you have not selected a synthetic voice, select Malcolm or Serena.
Yes, I have checked it all but no luck. Serena is selected by default. It only announces the arrival time now :( Has it got to do with the map update? It says that my map got expired about a year ago. It was all working fine last year for sure.
 
Yes, I have checked it all but no luck. Serena is selected by default. It only announces the arrival time now :( Has it got to do with the map update? It says that my map got expired about a year ago. It was all working fine last year for sure.
Try selecting another voice if still the same reset the device to factory settings.
 
It worked. It was muted 😟😟 I didn't notice the strike mark on the "face" icon next to the volume slider.
Thank you 🙏🏽
 
The en-route voice guidance suddenly stopped working on my Go Premium which is just 2 years old.. However the initial time of arrival announcemnt is still working and all the voices available in voice selection respond with the sample message when selected. I assume it is a software issue but can anyone tell me how to fix it.
I have tried everything I can think of bar a factory reset which I don't think would fix it, as well as wiping a load of routes I have set up for an upcoming road trip.
 
Hi there @nigel cross -
Your clip of an earlier posting by another user does not include your particular issue you may require assistance with.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,063
Messages
196,464
Members
68,066
Latest member
Cyberscouser

Latest Threads

Back
Top