via 135 keeps disconnecting during update

Discussion in 'Technical Support' started by ggqc, Sep 29, 2016.

  1. ggqc

    ggqc

    Joined:
    Sep 29, 2016
    Messages:
    7
    Likes Received:
    0
    TomTom Model(s):
    vias 135
    I'm trying to update software and maps on my via 135. it connects fine, and then downloads for a few seconds, and then I get the "connect device to computer" message again. the computer icon on the tom tom remains. I disconnect the tom tom, connect it again, and it resumes the download for a few more seconds, and disconnects again. After about 15 "re-connects", I have 24% downloaded. I have re-installed MyDrive Connect twice. Suggestions?
     
    ggqc, Sep 29, 2016
    #1
    1. Advertisements

  2. ggqc

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,072
    Likes Received:
    446
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    There is a bug in the MDC software. Disconnecting and reconnecting will (ultimately) result in a successful download ... usually.

    Also, an anti-virus or firewall may be hindering proper transmission. You might also try changing the default port in settings to 5000 or 5001.
     
    dhn, Sep 29, 2016
    #2
    1. Advertisements

  3. ggqc

    ggqc

    Joined:
    Sep 29, 2016
    Messages:
    7
    Likes Received:
    0
    TomTom Model(s):
    vias 135
    thanks i'll keep trying. I assume there will be a fix to the bug!
     
    ggqc, Sep 29, 2016
    #3
  4. ggqc

    ggqc

    Joined:
    Sep 29, 2016
    Messages:
    7
    Likes Received:
    0
    TomTom Model(s):
    vias 135
    Sooo frustrated. Finally got the update downloaded, but then it kept disconnecting when updating the device. Device now has nothing on it. Called support, and after trying trying to "fix" it, was told it was just the firewall interrupting. I needed to disable the firewall, and start over. Did that, with exactly the same results. Any suggestions?
     
    ggqc, Oct 2, 2016
    #4
  5. ggqc

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    11,008
    Likes Received:
    194
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Could be firewall OR some interaction with your AV software. For the time it takes to get the job done, try disabling both.
    Also, what physical port are you using on your PC? Or are we talking notebook? If PC, try a port on the rear if you've been using one on the front.
    Also, are you using the original TT cable? IIRC, it requires a fairly thin housing to sit nicely in the 135's connector, and most other cables are a good bit fatter in the housing, causing tension on the connection.
     
    canderson, Oct 2, 2016
    #5
  6. ggqc

    ggqc

    Joined:
    Sep 29, 2016
    Messages:
    7
    Likes Received:
    0
    TomTom Model(s):
    vias 135
    I have disabled firewall and av and tried again. No help, exactly the same results.
    I am using the original cable
    I am using a surface pro 3 with windows 10, so I only have 1 USB port
     
    ggqc, Oct 2, 2016
    #6
  7. ggqc

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    11,008
    Likes Received:
    194
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Are you familiar with the "USB Selective Suspend" option on your Surface Pro 3? Disable that, if enabled, during updates.

    1. Open Control Panel and tap Power Options.

    2. Tap on Change Plan Settings.

    3. Tap Advanced Power Settings.

    4. Scroll and expand USB settings.

    5. Expand the USB selective suspend setting and disable the option (both).
     
    canderson, Oct 2, 2016
    #7
  8. ggqc

    ggqc

    Joined:
    Sep 29, 2016
    Messages:
    7
    Likes Received:
    0
    TomTom Model(s):
    vias 135
    i don't seem to be able to find the USB selective suspend option. I went in to the change plans settings,advanced power settings, and USB settings was not listed. My choices under advanced settings power options were desktop background settings, sleep, power buttons in bed, display, and battery. No USB selection. Not sure where to go next. Suggestions?
     
    ggqc, Oct 2, 2016
    #8
  9. ggqc

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    11,008
    Likes Received:
    194
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Might be different than earlier versions. Take a look under "battery", which may offer the selective suspend as a power saving option, and if that doesn't get it, have a look under "sleep".
     
    canderson, Oct 3, 2016
    #9
  10. ggqc

    ggqc

    Joined:
    Sep 29, 2016
    Messages:
    7
    Likes Received:
    0
    TomTom Model(s):
    vias 135
    Success --finally. Thank you canderson, the problem was a power problem to the USB as you indicated. The USB selective suspend option is not available anymore on windows 10 (or at least not on mine), so you need to change the CsEnabled code in the registry. Found great instructions online to edit this specific registry code and it worked like a charm.

    This was after speaking to 2 different people at Tom Tom support with no help. Their final solution (since they couldn't get it to work), was to go to the library and use their computer, or maybe a friend's computer! Perhaps they should be required to read some of the forums to get answers.
     
    ggqc, Oct 8, 2016
    #10
  11. ggqc

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,072
    Likes Received:
    446
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Glad you got it sorted but, for sure, no Customer Service agent would -- or should -- suggest a user start to meddle with the registry on the user's computer.
     
    dhn, Oct 8, 2016
    #11
  12. ggqc

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    11,008
    Likes Received:
    194
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Sorry that I was a bit behind the power curve on the more recent OS settings configuration. VERY sorry to hear that it takes a registry hack to deal with this now. Wonder why MS removed that control option in later releases?!?

    Do you have a link for the registry hack that you can post for future users in case others encounter this? Or the full registry path to the CsEnabled bit?
     
    canderson, Oct 8, 2016
    #12
  13. ggqc

    ggqc

    Joined:
    Sep 29, 2016
    Messages:
    7
    Likes Received:
    0
    TomTom Model(s):
    vias 135
    Here is the link for changing CsEnabled in the registry. http://windowsitpro.com/windows-client/disabling-windows-connected-standby

    Interestingly, after making the change, the power options in control panel also changed. Balanced power is gone, and power saver is only option. However, the power saver program has USB Selective Suspend option available. Another change is that 'sleep' is no longer on start button, only shutdown or restart.
     
    ggqc, Oct 9, 2016
    #13
  14. ggqc

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    11,008
    Likes Received:
    194
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Many thanks. In the event that the link ever goes away, here is the requisite registry change:

    1. Start the registry editor (regedit.exe).
    2. Move to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power.
    3. Double-click CsEnabled and set to 0, then click OK.
     
    canderson, Oct 9, 2016
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.