tomtom 2535 WTE stuck at start time

Sep 24, 2008
I just got this unit from amazon. Everything was fine until today, when all of the sudden, the screen got stuck at the tomtom logo and it keeps coming back to the logo. Furthermore, it does not connec to the computer at all. What can I do? I have tried doing a soft start but that does not work either. When it is connected to the computer, the computer keeps beeping every 30 seconds as if it were connecting but then disconnects. Any ideas?
You have tried to hold the power button about 15 seconds until you hear the drum sounds?

And you are using MyTomTom web interface, not Home 2?

Clear your cache in the MyTomTom desktop icon under settings.
Thank you for the advice. I have cleard the cache but the point is that the device is not connecting at all. I am using the Tom Tom web interface. I have done the power button several times but still no luck. How can I send this device to Tom Tom so they can do something?
Had a look at your IP address and see you're in the U.S. - could have guessed - I would imagine your handle is the reverse of the town name, right?

You'll need to call tech support to get an RMA to return the unit.

866 486 6866

Monday - Friday: 7:00 a.m. to 11:00 p.m. EST
Saturday: 9:00 a.m. to 8:00 p.m. EST
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Latest member

Latest Threads