Pink Screen??

Discussion in 'Technical Support' started by Stumann, May 14, 2020.

  1. Stumann

    Stumann

    Joined:
    May 14, 2020
    Messages:
    2
    Likes Received:
    1
    TomTom Model(s):
    Start
    I have an older TomTom Start that has served me well for many years. I only use it maybe 2 or 3 times a years. I turned it on today and the screen is a pink color. Does anyone have any ideas why that would be? I know it's old, but as little as I use it, I don't want to invest in a new one.
     
    Stumann, May 14, 2020
    #1
    1. Advertisements

  2. Stumann

    Arno Moderator

    Joined:
    Jun 3, 2008
    Messages:
    3,549
    Likes Received:
    86
    Location:
    Toronto - Pickering, ON
    TomTom Model(s):
    930; GO 620; Start 63
    Don't know what it is but have you tried a drum roll boot>
    Hold the power button until the logo comes on and you hear the tom toms.
     
    Arno, May 14, 2020
    #2
    1. Advertisements

  3. Stumann

    Stumann

    Joined:
    May 14, 2020
    Messages:
    2
    Likes Received:
    1
    TomTom Model(s):
    Start
    I found the problem! I decided to take it apart and I found this ribbon cable that came loose. I guess I dropped it once too often. Anyway, it's back in place and working fine again.
     
    Stumann, May 14, 2020
    #3
    Arno likes this.
  4. Stumann

    Arno Moderator

    Joined:
    Jun 3, 2008
    Messages:
    3,549
    Likes Received:
    86
    Location:
    Toronto - Pickering, ON
    TomTom Model(s):
    930; GO 620; Start 63
    Congrats for finding it and thank you for letting everyone know. It may help the next one with the same problem.
     
    Arno, May 14, 2020
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.