Red.Pink & White stripes - help

Joined
Sep 25, 2010
Messages
2
I plugged in my TT One V2 into the mains elec to charge it. Suddenly on the left hand side of the screen (just under the connection) a series of coloured vertical stripes have appeared. The stripes remain there and I cannot even switch off. I tried to reset but nothing happened. I also tried to plug it into my TT Home but my computer no longer recognises it.
Is it dead? Please help.:(:(
 
Welcome to TTF.

so you are saying that even when you unplug it from the mains and it isn't connected to the computer, that the stripes remain and the power button has no effect? It stays on?

Also, a reset does nothing to alleviate the problem?

How long since the last time you used the unit?
 
Stripes

Thanks for that. I last used it in July of this year. Actually I started to charge it on an inside (of house) wall socket and all was well but I was not getting a sattelite signal so I took it to my outside power point and plugged it in and this happened. I fear that I may have damaged the power aspect or battery. What if I unscrew the four screws from behind and have a look, would that help?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
28,888
Messages
194,956
Members
67,842
Latest member
M Stedman

Latest Threads

Back
Top