I have a Mazda CX5 and am having problem with the current speed readout


Joined
Feb 27, 2014
Messages
2
TomTom Model(s)
MazdaNB1
I have just updated my NB1 software and am now finding a significant time lag on the current speed reading. It seems to be taking 20 secs to get back to zero after stopping and a similar lag when starting off. Also the Safety Lock message appears every time I accelerate. Any ideas for fixing this
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,275
Location
Toronto Canada
TomTom Model(s)
Go 50; Go 520
Are you able to hold the power button about 20 seconds till you hear the drum sounds?
 
Joined
Feb 27, 2014
Messages
2
TomTom Model(s)
MazdaNB1
Are you able to hold the power button about 20 seconds till you hear the drum sounds?
This is an in-dash Nav system (Mazda NB1) and as such does not have a power button
 
Ad

Advertisements

Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
1. I just had a look at the NB1 manual (available to download HERE) and on page 10 it mentions the "Safety lock" feature. Unfortunately, it doesn't mention any way to turn it off.

2. Page 4 has details on how to do a reset...
In rare circumstances, you may need to reset your navigation device. To reset your device, switch off the car engine and then remove the memory card. Re-insert the memory card and switch the car engine on again.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top