Go 51 not recognised by PC following update

Discussion in 'TomTom Home and MyTomTom Software' started by Ian_B, Apr 26, 2017.

  1. Ian_B

    Ian_B

    Joined:
    Apr 3, 2011
    Messages:
    4
    Likes Received:
    0
    Location:
    Blackpool, Lancs, UK
    TomTom Model(s):
    TomTom Go920
    Plugged my Go 51 into my PC today and was notified there were 4 updates - one OS and 3 maps/community updates. The OS update was applied and after that nothing else worked. I see that other models have had similar issues that required authorising Beta software - but this didn't work for me.
    The Go51 says its connected to the PC. The PC makes the USB device connect/disconnect sounds, but My Drive Connect doesn't report the device, nor is it visible in Device Manager.
    Any suggestions?
     
    Ian_B, Apr 26, 2017
    #1
    1. Advertisements

  2. Ian_B

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,616
    Likes Received:
    403
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    dhn, Apr 26, 2017
    #2
    1. Advertisements

  3. Ian_B

    Ian_B

    Joined:
    Apr 3, 2011
    Messages:
    4
    Likes Received:
    0
    Location:
    Blackpool, Lancs, UK
    TomTom Model(s):
    TomTom Go920
    Ah! Found it. It had been deactivated. I enabled it again and all is well!
    Thanks
    Ian Birchenough
     
    Ian_B, Apr 26, 2017
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.