Expert 7" stops charging on mount after a few minutes

Joined
Sep 10, 2022
Messages
11
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Rider 550
My Tomtom Expert 7" will charge if I plug directly into the unit, but when I put it on the mount it stops after a few minutes. It will still work, and comes on when I put the device on the mount. But the second I take it off, it shows red battery and shuts down.

It hasn't always been like this, only started happening last few weeks. I have tried a different lead, and I think I have narrowed the fault down to the mount itself.

Is there any way to fix this?
 
This is driving me nuts. I bought a new mount because the micro USB plug was loose. And for a short time it worked, but now it won't charge again, or even stay on once the battery is depleted. I've tried a different stick charger, different leads... nothing seems to keep it reliably charging.

I've been reduced to taking it off the mount and giving it refresh charges directly to the port on the back while I'm working outside the cab. Or even resorting to Road Lords app when it is too low.

I really don't know where to go from here. Less than a year old... that mount system is just such a bad design.
 
If the device is less than a year old, it should be able to be returned under warranty.
 
I never thought of that. Cheers!
I have exactly the same issue as you. I bought my tomtom go expert 11 months ago, and today I'm going to Halford to give them back, but I'm not sure if they will accept it back or not.
 
I have exactly the same issue as you. I bought my tomtom go expert 11 months ago, and today I'm going to Halford to give them back, but I'm not sure if they will accept it back or not.

I ended up replacing the mount, the cable... and now it charges but sometimes I have to tap it to make it charge. I think the heat in the window may have made a solder joint go weak.
 
I have exactly same problem with my Expert it won't charge on cradle but will charge when plugged directly into sat nav , also I have to clean windscreen every time before attaching sucker but it still falls off during journey.
 
I bought my Expert May 2023 and after every job I have to remove it from the Coach windscreen disconnecting cable from cradle which I think causes the cable to become loose aswell.
 
I bought my Expert May 2023 and after every job I have to remove it from the Coach windscreen disconnecting cable from cradle which I think causes the cable to become loose aswell.
Your GO should still be under warranty, contact Tomtom to see if they can make the warranty work.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,155
Messages
197,157
Members
68,213
Latest member
JMS

Latest Threads

Back
Top