Can't log in to forum

Discussion in 'General TomTom Discussion' started by rondeco30, Aug 10, 2019.

  1. rondeco30

    rondeco30

    Joined:
    Jul 21, 2011
    Messages:
    17
    Likes Received:
    0
    I'm having trouble when I try to log in at discussions.tomtom.com it keeps telling me I'm banned! I can't find a contact email for admin at all. Can anybody help?

    T.I.A.
    Ron
     
    rondeco30, Aug 10, 2019
    #1
    1. Advertisements

  2. rondeco30

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,023
    Likes Received:
    445
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    I've left a message for one of the moderators. You'll have to wait till Monday to hear anything I suppose.
     
    dhn, Aug 10, 2019
    #2
    1. Advertisements

  3. rondeco30

    rondeco30

    Joined:
    Jul 21, 2011
    Messages:
    17
    Likes Received:
    0
    Thank you, will keep you posted.
     
    rondeco30, Aug 11, 2019
    #3
  4. rondeco30

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,909
    Likes Received:
    188
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Could be the avatar :eek:
     
    canderson, Aug 11, 2019
    #4
  5. rondeco30

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,023
    Likes Received:
    445
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    I'm informed you should be able to log into the forum now.
     
    dhn, Aug 12, 2019
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.