Can't log in to forum


Joined
Jul 21, 2011
Messages
17
I'm having trouble when I try to log in at discussions.tomtom.com it keeps telling me I'm banned! I can't find a contact email for admin at all. Can anybody help?

T.I.A.
Ron
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,143
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
I've left a message for one of the moderators. You'll have to wait till Monday to hear anything I suppose.
 

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,252
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Could be the avatar :eek:
 

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,143
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
I'm informed you should be able to log into the forum now.
 
Joined
Feb 24, 2008
Messages
22
TomTom Model(s)
GO 1005
I have the same issue.
I haven't been logged in to discussions.tomtom.com for a long time, and when I tried to today it told me I was banned.

Can anyone please help?

I also cannot download any updates through MyDrive Connect. It tells me that the servers are busy. Can it be related?
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,143
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
This forum is NOT associated with the official tomtom.com discussion forum whatsoever.

But I've reached out to a moderator there to see what he can do about the situation.
 
Last edited:
Ad

Advertisements

Joined
Feb 24, 2008
Messages
22
TomTom Model(s)
GO 1005
I am using a different email there, sent it to you in a PM.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top