920 won't boot; explorer shows tomtom disks are unformatted

Joined
Jan 3, 2008
Messages
3
Hi all,

Got my tomtom 920 about a year ago. No problems. Tried to boot today and it wouldn't boot -- stuck at splash screen with the red circle and the white X.

Came home, read some forums, and it sounds like this is a file/formatting error. I install HOME, pop the tomtom in to my computer, and the computer recognizes two removable disks, both 0 bytes and unknown file system. Double clicking on these prompts me to enter a disk, so something is pretty wrong :-( Because of this, I can't even format the drive.

HOME doesn't detect the device as being attached to the computer, presumably because it can't read any files on the unit.

I don't have a backup.

What's my best option? Help! I felt naked driving around today without this sucker.
 
Last edited:
Thanks for the reply!

Pin reset doesn't work.

Because the device is not seen by HOME, the solution 1a isn't applicable. Because the removable drives are seen by windows but claimed to be empty, I cannot format as discussed in 1b.

2a isn't applicable because the device is seen and recognized by windows (it just claims there's no data/disk on the drive). 2b, same deal. HOME won't see it. 2c is not applicable because the drives are recognized by windows.

I'm thinking my best bet is to contact tech support. If anyone else has suggestions, I'm all ears! Thanks in advance.
 
Try doing a chkfdk /f on the internal memory of the unit. And on the sd disk, too).
 
I had something similar happen to me. The computer(s) refused to recognize the 910 following a firmware update. TT tech couldn't help. They downloaded a file for me to install, but since computer didn't know the TT was connected, no way to download. Also, couldn't reinstall my backup. Ultimately, TT took back the unit and sent me a refurb in its place. Hopefully, you're still under warranty.
 
Last edited:
In a SUPER annoying turn of events, tonight as I was going to call tech support to get a replacement, I turned on my tomtom and it booted right up. Now I have a non-trustworthy unit to rely on :(

Has anyone had a tomtom come back from the dead?

I'm currently backing up the tomtom before I do a system upgrade on it...
 
Make sure it is an Explorer, not Home, backup and ensure hidden files/folders are showing.
 
Help! Same problem!

Hey all, I know this is an old thread, but I'm having the EXACT problem. I think I might have disconnected it improperly after an update.

I need this to work TONIGHT, or else I'm pretty screwed.

Are there any other ideas other than the chkdsk? I'm at work right now, and I have doubts that will work, and I don't want to lose all my bookmarked locations. Anybody out there that can help me in this emergency?

:eek:
 
If you have a 920, extract this file onto a blank SD (2gb or less size). See if it starts up. Then go to change map and see if it can find your map on the internal memory.

If you have a 910 and the computer can't see the Tomtom, you don't have many options unless you want to disassemble and plug the hard drive into a linux machine.

If you have a different model, please let us know as troubleshooting steps can be a bit different. Also, let us know if it was an application update or a map update.
 
I have a 920. It was an application update, which I had updated from a Mac, as opposed to a PC, which I had normally been using. Maybe I corrupted something when I detached the GPS incorrectly from my Mac. It kept starting up, only to freeze and then reset itself back to normal, and would run fine. After a few days, nothing.

If the SD cards works, what then do I do? Do you think the issue is with the map, or the system files?
 
If the SD card works, then I'd leave it alone for your evening emergency. That also means you can once again see the internal memory when plugged into a computer.

Then once you have more time:
1) run a chkdsk /f on the internal memory
2) delete all files in the root of the internal memory (but no folders)
3) then let tomtom HOME reinstall everything, using the blue disconnect button every time before unplugging
 
OK. I'm at work now, so when I get home I'll pick up a card and give it a shot. I have to go to my Army Reserve drill this weekend (and I have no clue where I'm going, but I have to get there fast, hence the need for the GPS) so I'll try the other stuff when I get back on Monday. So much for the weekend ;)

Two questions - if I run the chkdsk, wouldn't my computer be reading what's on the card, and not the internal memory of the GPS itself?

And, since I don't have access to the GPS at this moment, are you telling me there's a blue button on the unit itself that I need to press in order to disconnect? Naw.... you must mean the HOME program.... I hope....
 
Explorer should see two drives: the internal and the sd card. Highlight the drive reflecting internal, right click, properties, chkdsk on it.

The blue button (cursor) is on the screen of the unit, not on the unit itself.
 
The blue button I'm referring to is on the lower right of the HOME application on your computer.
 
The SD card worked, and I can see both the internal drive and the card on "My Computer", but I still can't access the internal drive. I can access the device through HOME, but it comes up with a "No Maps" screen.

Whenever I try to run chkdsk l: /f in the cmd box (windows xp) I get an error, saying that the computer "Cannot open volume for direct access."

I feel like I'm on the verge of it, but I still can't get to the freakin drive! How can I access this?
 
Last edited:
When connected to HOME, choose the extenal SD when it asks. Then in HOME, go to add a map (hopefully you have one on HOME from previously, so you don't have to pay), and add the map to the SD. Once you have more time, we can walk though the troubleshooting steps to fix the internal.

Maybe you have to close HOME before running the chkdsk, something is locking it from chkdsk's required exclusive access.
 
I bought the unit in an American Army post exchange in Germany. I know it had a western european map installed. I cannot for the life of me remember how I purchased maps to the US once I moved back to New York. Was it by DVD? It had to be, because nothing other than the Traffic Service is showing up in my online account. So basically I have two maps locked away in a GPS internal hard drive that I cannot access.

When I try to access the L: drive in CMD mode, I get an error. I took your advice, closed the Home program, and scanned task manager for any TomTom related service stuff, which I also closed. No dice, still can't access the L: to chkdsk it. I right click on the drive on "My Computer", properties, tools, error-checking > check now, and it doesn't scan. Right when I hit "Start", it closes as if I pressed cancel.

I'm home for the week. I can do some more intense troubleshooting now. Thanks for the help so far.
 
Seems like your drive is corrupted. Try this program on the drive. If it can't find your maps, nothing will.

If you can't recover your map folder, then you'll likely have to pay for a new map. You can probably format the internal drive to get it working again, but before you try that, call Tomtom support and play dumb (as if you didn't previously get hints here). Just say it's broken and you'd like them to help you fix it. Sometimes they'll be nice and give you an older map for free to get it functioning properly.
 
I'd love to recover my map, but unfortunately, like everything else, that program says it can't access it. It's as if they're all seeing that it's an empty disc drive. I'm completely locked out.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,063
Messages
196,464
Members
68,066
Latest member
Cyberscouser

Latest Threads

Back
Top