XL340S Firmware and map update went fine

Joined
Nov 30, 2009
Messages
29
I've had my XL340S for a week, and updated the firmware and map last night. I'd already deleted all the voices except Susan and Dave to be sure I had enough space for the updates.

Downloading the new map took about 38 minutes. Loading it into the unit took around 1+ hours.

This is my first GPS so I've never done any of this before, but everything went fine, no problems.

New updates:
firmware: 9.022.457667.2
map: v840.2568
 
Good news!

Make sure you make an Explorer, not Home, backup of your unit's contents.
 
I've had my XL340S for two days. Both Dave & Susan do not speak, all of the other voices seem OK. My unit itself shows that the voices are installed on it. When I try to operate it using TomTomHome on my computer these two voices are not there.
I did save everthing originally using Explorer and I also,saved my new map download seperately.
I am using Win 7, maybe this is my problem? When I plug it into my computer, I get a Win7 screen that asks me if i want to repair my memory in the unit.
Any advice?
Thanks, Dave
 
You cannot select and use a computer voice using Home's emulator (Operate my Unit). They can only be selected on the unit itself.

Since you do have an Explorer backup (good person!!), you may want to format the drive (not quickformat) and use Explorer to copy your backup onto the unit again
 
Last edited:
Do you have another PC available to use that isn't running Windows 7?

The reason I ask is we seem to be seeing far more devices with faults during updates to the Navcore/ map files with people at the moment, not all of them have been reporting the computer OS but the sudden increase in bricked devices seems more than a coincidence to me with the recent release of the latest version of Windows.

The fact your PC is reporting errors and wants to play around with the files stored on the device offering to "repair" the files sets alarm bells ringing to me, the TomTom is running a specific Linux based system which the PC won't like certain essential files (any thing seen with a .chk file extension will get deleted) and these files are needed by the TomTom, without them it will refuse to boot.

I have been bitten before with MicroSoft updates to the PC, this is probably why I don't like the idea of using Windows 7 at the moment with a device running Linux, its also fair to say MicroSoft probably didn't test all the TomTom devices with the OS prior to release so tread carefully - Mike
 
mikealder, you are right. Some of the .chk files are missing now on my unit, they are on the back-up OK. Any Windows program will not like *.chk files as they are generally just left over junk for most people. I am formatting with Win 7 now using full format and it is formatting in the original FAT.
It looks like it will take forever to format, maybe not forever, just 1 to 2 hours!
Unbelieveable, USB 1.1 in this day and age. I have been only able to buy USB 2 in anything I have purchased for probably over 2-3 years now.
Thanks, Dave
PS: I reported that I was using Win 7 as I had read many other TomTom posts and Win 7 was mentioned several times as being a potential problem.
PPS: 20-25% formatted now in about a ? hour!

Edit: Will I just be able to copy my saved new map info over the old map info? i will delete the unused voices 1st to give me enough room.
 
Last edited:
I reformatted, reinstalled, upgraded and then reinstalled my latest saved map and it seems to be working OK. Both Dave and Susan are speaking now. Thanks for all of the advice and help. I did it using Win 7 and it generally went OK except for one minor glitch.
During one of the upgrades it couldn't create index_es.html which is located at \helpme\other\travelinfo\index_es.html. I tried twice and it failed both times at the same place. I then located the file and saw it had 0 bytes (should have been about 57-61), I tried to open it, it was corrupt. I deleted it from the TomTom XL340S and tried the upgrade again. It sailed right thru it and I then continued with all the other upgrades and then reinstalled the new map. Success!
I must admit, this is the most time consuming thing that I have ever experieced in the last several years. It took about 6 hours to do everthing, USB 2.0 would have probably cut the time to about 1-2 hours. Hopefuilly I don't have to do it again.
Thanks again, Dave
PS: I am running a DEMO now, it's working great, Dave is talking and the view looks good.

Edit: Everytime you connect it to the computer a screen comes up that says "Do you want to scan and fix TomTom?" and it says it is highly recommended. Don't do it!
 
Last edited:
Your PC might be USB 2 but the TomTom isn't to save cost they fitted the XL devices with USB 1 but even so something isn't quite right as it shouldn't be taking this long to update a device, around an hour would be correct - We have seen this before with other XL devices where the USB driver loaded to the TomTom was sub-optimal, perhaps an update at some future point will address this.

As for Windows 7 reporting errors everytime you connect the TomTom, just ignore it but make sure you hit "Cancel" rather than repair! - Mike
 
Updates usually do go fine. Esp if you research beforehand...Good for you, glad it worked out well...
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,047
Messages
196,333
Members
68,048
Latest member
Cranbrook

Latest Threads

Back
Top