VIA 620 will not connect.

Joined
Dec 16, 2018
Messages
3
Country
<img src="/styles/default/custom/flags/ca.png" alt="Canada" /> Canada
TomTom Model(s)
VIA 620
I am using a VIA 620 with the supplied USB cord attached directly to my OSX 10.12.6. In the past I have connected it via Tom Tom My Drive Connect and have installed updates. Now, for the longest time, it will not connect although it tells me I have five updates waiting for me. I have removed and reinstalled My Drive Connect to no avail. i have checked the device in my system preference Network control. It shows there with the desired orange button, meaning it is properly connected and functioning. Nonetheless I have removed it, reconnected it and renewed the DHCP lease, again to no avail. I have searched the official site and followed all the suggestions I can find. It shows "connecting" when plugged in but, after timing out, it says the server is busy, try later, or "not responding".

Any help or suggestions would be appreciated.
 
Don't know anything about the Mac, sorry, but isn't the orange colour an alert that something is not working properly.
 
Not according to Tom Tom postings. Orange is said to be recognized and working properly.
 
OK. I only remarked because a brief Google search showed

Screen Shot 12-16-18 at 10.29 PM.JPG
 
One thing you said caught my attention. "...renewed the DHCP lease...". Eh? Your 620 does indeed look like a network adapter (thanks to the MyDrive app that does the USB to TCP bridge), but it should have a static address of http://169.254.255.1. It's not a DHCP device. In fact, it might be worth typing that address into your favorite browser address bar to see if the 620 responds.

Specifically, try this url >> http://169.254.255.1/personal

That should garner some sort of response from the device if it's able to be contacted at all, even if you don't have any custom POI's loaded.
 
Thanks for your response, canderson. I tried your suggestions and got the same result as with My Drive Connect, it just times out. Very frustrating.
 
I am having the same problem. My tomtom via 620 shows I have 4 updates it but it says "not connected" beside an orange circle with an exclamation point in the circle. I have been able to update in the past. I do have the cable connected to my computer. Any ideas?
 
Do you mean Go 620? If so, the 620 is designed to get updates using WiFi, not MyDriveConnect. But you can use the usb cable with MyDriveConnect running BUT minimized and the device connected to the computer.

For further help, call support:

1f1fa-1f1f8.png
United States
877-757-7137
Monday - Friday: 9:00 a.m. to 7:00 p.m. EST
 
According to MyDrive, I have a Via 620 S/N WN1463F02787. Now I got it to connect, but it says I do not have enough space to do the update. I have removed everything, including the voice and it still says I do not have enough space. Any ideas?
 
Yes. Get yourself a 16 gb SanDisk microsdhc card and insert it into your device. Let the device format it in its proprietary method and you should be good to go for map expansions and additional maps. The likely location for the sd card slot is where the cable connects to the device but other possibilities include the bottom under a removable cover and the back of the device.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
28,893
Messages
194,968
Members
67,843
Latest member
Merciful

Latest Threads

Back
Top