Urban Rider will not start up

Joined
Jul 1, 2013
Messages
1
Location
Switzerland
TomTom Model(s)
Urban Rider
Hi, I have had my Tomtom Urban rider for exactly two months now, and it just will not start up.

I have charged it overnight twice now, as soon as I plug it into the wall socket or my iMacs usb port the screen lights up with the relevant messages or menus, I can even connect it to the computer and update maps etc, but when I unplug it and push the start button nothing happens.

I have read on the Tomtom website that the Urban Rider can be reset by holding the start button in for up to 30 seconds, but this does not do anything on my rider.

When I push the button I can hear and feel the button "activate" but nothing more happens.

I have always taken perfect care of the GPS and it is still in imaculate condition.
Can anyone give me any advice on how to solve this - i'm considering returning it to the store, but i'm slightly reluctant to un-install all the mounting brackets and scala rider accessories.

Best regards.
 
Sure sounds like a battery issue. Unfortunately, you may indeed need to return it. Anyway, give CS a call:

Suisse
0844000091

du lundi au vendredi de
09h00 à 17h30 CET

[have moved thread to a more relevant forum for increased visibility]
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
28,761
Messages
193,874
Members
67,630
Latest member
pennywood

Latest Threads

Back
Top