tomtom xl 330S woes

Joined
Jan 19, 2011
Messages
6
Location
U.S.
TomTom Model(s)
xl 330S
I have a 330S that is having problems.I did a n update from tottom site and now am running into problems.When you try to type in a zip code or type in a letter the next number will appear on the screen,such as type in the number 3 and you will get 4 or type in the letter R and you get S.I tried to do a factory reset as I had nothing but home added to it but did not help.Any help would be appreciated.
 
Have you tried resetting the unit by holding the power button for about 10 seconds? (I don't think that model has a dedicated reset hole).
 
I notice now the device will not find gps signal.I went outside on porch with clear view of sky waited almost 5 minutes still could not find gps signal.
 
Just tried that earlier this morning.problems seem to be getting worse.I also noticed after putting it to factory settings that after letting it check for updates it shows no updates.
 
finally got it to pick up satellites but noticed that navigate to,find alternative and add favorites was greyed out
 
Final update::: I got techinal support at tottom they walked me through some steps but would not help the problem.Basically told me that since it was a little over a year old that the trash can was the best place for it.
 
What kind of update did you get and do you happen to have a backup, hopefully made with Explorer, prior to this problem happening?
 
What are the first 2 letters of the serial number on the bottom? There are some things we can do to attempt to revive it.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,146
Messages
197,060
Members
68,199
Latest member
Boothy

Latest Threads

Back
Top