Problems with XL330S - what I did to fix it

Joined
May 10, 2010
Messages
1
I have a XL330S that's been giving me lots of trouble. Actually, it's one I gave my daughter for Christmas, and I don't know that it has worked very well since then. This morning, I finally have gotten it working correctly, at least so far. One big problem was that when I would download updates, as the computer would try to install them onto the TomTom, the transfer or copy would stall and abort the process. I've spoken with TomTom support at least five times in the past week, and here are the various tips they gave me, in the order of what I think are the most important:
1. Connect the USB cable to the computer through a REAR port, i.e. not one on the front of your computer. I had been connecting through a hub, and using a port directly on the computer may have solved the problem, but when I took it out of the hub and put it in the rear port, all files finally transferred to the TomTom. Until I did this, I thought this suggestion was silly, but it worked.
2. Don't use TomTom Home 2.7. They gave me a link to roll back to 2.5. Who knows, but that's what they said. They said "there are issues with 2.7," which begs the question: why did you release it? Here's the link:
http://download.tomtom.com/sweet/application/releases/v2_5_2_60_win.exe
3. Use Windows XP. I could't do this; Win 7 is all I have now.
4. Use a computer with a wired internet connection, not wireless. Mine was wired, but I think this suggestion is also kinda lame, but it's what they said.
5. Disable your antivirus and your firewall. I have some MAJOR problems with this suggestion. As long as TomTom Home is the only application open, and I'm not doing any web browsing at the same time I'm trying to update the TomTom, I feel okay with no antivirus. But, to ask me to disable my firewall is asking too much, especially since sometimes it can take almost an hour to get the TomTom to update, and during that time, I feel really vulnerable with no firewall. I did it, because they told me to, but the difference was when I plugged the USB in the rear, and I had tried to go without antivirus and firewall before, and it still aborted.

MY THOUGHTS:
Don't use a USB hub, connect directly to the computer, and if you're still having trouble, connect to the rear, which I assume means you're connecting directly to the motherboard. Also, BE PATIENT, it takes a very long time to transfer files. I read on some forum posting that these things are something like USB 1.1, which means nothing happens very fast.
If you keep trying and it won't work, copy everything on the TomTom to a separate directory on your computer or external drive or somewhere as a backup, and then reformat the TomTom. But, if you're going to do this, use a rear USB port, and make sure you also copy hidden files and directories. After reformatting, TomTom Home sees the unit and then will try to reinstall everything. Also, if you decided to reformat, BE PATIENT. Mine took 5 - 6 hours. See the USB 1.1 comment above.
After I finally got everything working, and I think it is working well, I made another backup of everything on the TomTom, so that if it acts up again, it <should> be easier to get back to where I am now.

My daughter HAD BETTER appreciate this!
 
Welcome to TTF.

The 330 model certainly does have issues with updates. The point four by CS is correct in that for some reason large file downloads (applications and especially maps) tend to drop data sometimes in the transfer from TT's servers and your computer.

And of course the suggestion to disable your anti-virus during a dl is stupid.

There is nothing like an Explorer, not Home, backup to get people out of some problems. We preach that here all the time.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
28,884
Messages
194,919
Members
67,837
Latest member
kimvandenberg

Latest Threads

Back
Top