never seen this fault before - any ideas?

Joined
Jul 1, 2009
Messages
2
The TomTom rider is now well out of warranty. It has been resting in the glove box of the car for a few weeks. I switched it on (as always with great difficulty) the other day and a stream of data appeared in old fashioned computer text. About 20 lines of white text with all the diagnostic data, touchscreen type, CPU id, Checksum Bootloader version, et etc.

I reset it, powered it down, and have now left it a week powered on with battery only, so that it well and truly resets.

Switched on again today and the same problem. It has managed to let me down in numerous ways before, but this is a new one. Does anyone have any ideas???

Thanks
Adam
 
The on/ off switch is stuck in the on position as the only way to get that screen to display is by holding down the on/ off switch - Mike
 
Thats kinda what it sounds like alright. You get that screen if you hold the on switch on for about 10 or 15 seconds.

Beyond that, not sure what to tell you.

Cheers
 
Hi Adam
It is a strange conincidence that I have just experienced a very similar problem. My Rider 2 began to boot up but hung with all the lines of white text that you have described. I attempted to connect my Rider to my computer and TT Home but it wasn't even recognised by my computer as having been connected to the USB port. I did a hard reset but the unit would not shut down. I contacted TT Support and they requested that I send it in for them to look at (this is a major hassle as the Rider is not available in New Zealand and I have to courier it to Australia) I have just recently received my unit back and the repair note that arrived with it describes the repair as: UPDATED BOOTLOADER. Now what that is I don't know for sure, but it sounds like a software corruption problem to me???
Any one else had any similar experiences? My Rider will be out of warranty now that it is December so I am hoping that I don't have this problem again.
PC
 
Firstly, many thanks to MikeAlder - you were correct with your diagnosis - the switch was jammed on
Secondly thanks to the YouTube man (Microwizard) who shows how to pull the rider apart
Thirdly thanks to Amazon for doing such a good deal on the Torx spanner set to undo the hidden screws on the back of the Rider.

So what did I do? - Followed Microwizard's instructions - these took a week to complete, due to having to wait for Amazon to deliver.

Disconnected the battery and the GPS chip + the on bike charging point (all push fit connectors)

Unscrewed the 6 mini torx screws around the main circuit board to take the actual unit, including the screen out of the case

There is a bit of metal pushed over the actual switch - I released this and made it fit less tightly and hey presto, it switched on great

I took the opportunity to deep clean the screen - right to the edges

Reassembled the unit

Slight panic in that it wouldn't switch on, but through trial and error tried switching on with a very long (15secs) press of the button - and all works great.

THen screwed the back into position to seal the unit.

Now I know what the switch action is, and I have loosened its metal surround, I can feel/hear the slight click as it activates. I never could do this before.

Looks as if there may even be a new set of maps bought for the dammed unit...rather than it be binned and a Garmin bought

Thank you Mikealder for pointing me int he right direction

Regards
Adam :)
 
Glad to hear you have fixed it as not everyone will attempt to take a unit to bits! - Mike
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,046
Messages
196,311
Members
68,048
Latest member
Doug Heydon

Latest Threads

Back
Top