My TomTom died today for no apparent reason

Discussion in 'General TomTom Discussion' started by godsdragon, Sep 12, 2009.

  1. godsdragon

    godsdragon

    Joined:
    Sep 12, 2009
    Messages:
    3
    Likes Received:
    0
    Please help, I went to turn on my TomTom today and it remained off, I know it was charged for I keep it charginf all the time while my car is running.
    :(
     
    godsdragon, Sep 12, 2009
    #1
    1. Advertisements

  2. godsdragon

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,106
    Likes Received:
    448
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Have you tried a reset of the unit? Not sure whether your model has a dedicated reset opening on the bottom. If not, try to hold the power button for about 10-15 seconds.
     
    dhn, Sep 12, 2009
    #2
    1. Advertisements

  3. godsdragon

    godsdragon

    Joined:
    Sep 12, 2009
    Messages:
    3
    Likes Received:
    0
    Yes I have tried resetting to no avail... Thanks for your prompt response
     
    godsdragon, Sep 12, 2009
    #3
  4. godsdragon

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,106
    Likes Received:
    448
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Well, can you connect it to a usb cable overnight and see if it starts in the morning?
     
    dhn, Sep 12, 2009
    #4
  5. godsdragon

    godsdragon

    Joined:
    Sep 12, 2009
    Messages:
    3
    Likes Received:
    0
    Yes, thats what I am going to try to do. In the mean time the reset option will not work as the gps is totally dead...
     
    godsdragon, Sep 12, 2009
    #5
  6. godsdragon

    luvcows

    Joined:
    Sep 13, 2009
    Messages:
    1
    Likes Received:
    0
    Location:
    Ohio
    TomTom Model(s):
    TomTom One
    similar issue

    Ive only had my TomTom One since May and used it 4 times so far. Today I had a hard time getting it turned on. Then while driving the screen went totally black. I thought it turned off but now I think it is actually on but no screen. I can hear it connecting on my pc but still no screen. I have also tried the reset several times to no avail.
     
    luvcows, Sep 13, 2009
    #6
  7. godsdragon

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,106
    Likes Received:
    448
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Since it is under warranty, I'd call support at 866-486-6866 for a RMA
     
    dhn, Sep 13, 2009
    #7
  8. godsdragon

    Jim S.

    Joined:
    Jun 21, 2020
    Messages:
    4
    Likes Received:
    0
    TomTom Model(s):
    VIA1525TM
    Try pressing the button 3 times in quick succession just before the unit boots up.
     
    Jim S., Jun 21, 2020
    #8
  9. godsdragon

    Arno Moderator

    Joined:
    Jun 3, 2008
    Messages:
    3,532
    Likes Received:
    85
    Location:
    Toronto - Pickering, ON
    TomTom Model(s):
    930; GO 620; Start 63
    11 years ago it didn't work like that.
     
    Arno, Jun 21, 2020
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.