Help with TomTom 910 please!


Joined
Sep 7, 2011
Messages
4
Hi there,

While trying to repair my tomtom 910 I think I may have killed it! I have 2 tomtoms a 300 and a 910 (his 'n' hers!) which I have backed up onto my PC using explorer.

My 910 has been playing up recently so I decided to wipe it and replace the files with the ones I had backed up. I connected it to the pc, deleted the files replaced them with the backed up ones, turned it on and got an error message saying the map cant be used. Then it dawned on me, what I have done is put the backup files from the 300 onto the 910 and so the map won't load.

To cut a long story short, I am not stuck in a vicious circle. I turn it on, it tries to open the map, cant do it, tells me to pick a map (the only one available is the one that wont work) and wont let me start it without selecting a map :mad:

All I want to do is connect it back to the pc and put the correct backup files onto it but it wont connect to the pc without me choosing a map!

Any suggestions on how I can sort this out? Can I remove the HDD and plug it into my PC to replace the flies?

Any help will be greatly appreciated :thumb:

Thanks, Tom
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,182
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Welcome to TTF.

Can you connect the 910 to the computer and have it recognized as a removable drive. Use Explorer and delete all the loose files in the root of the unit, NO folders or their contents.

Then connect to Home and a new application should be offered (I think it's 7.903 for that model. Install it and remove the unit properly from Home using the Device Disconnect icon.

If you've gotten this far, reconnect to the computer and, from your backup, copy the specific map folder from the backup.

Try that......................
 
Joined
Sep 7, 2011
Messages
4
Hi dhn,

Thanks for the reply :thumb:

Unfortunately when I connect the tomtom to the PC it does nothing! I've tried a few different usb ports and cant get the pc to recognise it. It was working before I copied the files.

Once I can get it to connect to the PC again I should be OK, but cant get it to work.
 
Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
The only way forward really, is to get it recognised by the computer.
It *should* be recognised as a hard drive even if there's nothing on it at all!!

You haven't mentioned doing a reset (straightened paper clip in the tiny hole on the bottom). Have you tried that?



Normally, I'd suggest trying a different lead as well, but you're a bit stuck as that model has a home dock with a fixed USB cable, doesn't it?

Got another PC you could try it on? It doesn't need Home installed for this test. Just see if it will let you connect.

If all else fails, at least (from your name) it loks like you're in the UK and at least we have access to a TomTom repair centre and a few independent repair shops
 
Joined
Mar 23, 2009
Messages
3,199
Location
Blackpool UK
TomTom Model(s)
720, 930, 940, XL, One 3rd
With a 910 the reset hole is very small either use a very thin paperclip or better is a pin, you will be able to feel the reset switch depress then switch it on and try connecting to the PC make sure the power cable is also secure in the home dock on this model as a 910 employs a spinning hard drive which is more power hungry than a flash memory based device - Mike
 
Joined
Sep 7, 2011
Messages
4
Hi Andy_P and mikealder,

I tried the pin reset last night and found out that the hole is very small, had to use a sewing needle in the end! But unfortunately got the same result.

The 910 has got the stupid home dock so can't try another but have just noticed something that may shed some light as to why it's not working. When I put it on the home dock with the power cable plugged in the charge light doesn't come on. I had to put it in the car holder last night to charge. Does this mean that the dock is the problem?

I've tried 2 computers running different OS but still nothing. I am based in Wales, but with the price of repair centres and a young baby needing a new car seat I would be happier if I could fix it myself :)

Thanks
 
Ad

Advertisements

Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
When I put it on the home dock with the power cable plugged in the charge light doesn't come on. I had to put it in the car holder last night to charge. Does this mean that the dock is the problem?
That certainly sounds like it could be the problem.

I can't remember for sure, but I think there may be some active electronics in the home dock, so it would need good power input to work.

Do you have access to a DC voltmeter? If you do, can you check the voltage on the DC connector of the home charger (the one that plugs into the dock.

It should be +5 Volts in the centre and 0 Volts on the outside.

Hopefully that power supply has died rather than the dock itself, as the charger should be easily replaceable with a third-party one from somewhere like Maplins.
 
Joined
Sep 7, 2011
Messages
4
I think the power cable is fine as I plugged it into the car mount to charge it in the house last night.

I'm sitting here now alongside the dock and I've been having a little play, moving it around and the green charging light came on and the tomtom is now connected to the PC! I guess the dock is getting to be a little touchy and will have to persevere in future and keep wiggling it till the light comes on!!

Thank you all for your help! :)
 
Ad

Advertisements

Joined
Mar 23, 2009
Messages
3,199
Location
Blackpool UK
TomTom Model(s)
720, 930, 940, XL, One 3rd
The mount on the x10 series was never very good although with the Home dock the issue was more often the power lead connection becoming loose. Towards the rear of the base is a small rubber bung/ plug you can try removing this and see if the device sits on the dock any better. Some users used to find the ddevice connected better without the bung, others found the oposite but its only a push fit so its worth a try - Mike
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top