GO6000 "Bricked" by adding premium voice


Joined
May 9, 2014
Messages
1
TomTom Model(s)
GO930, GO6000
I have been in regular contact with you support desk CCARE-997 (incident:140501-000691), but everything you seem to do seems to make my GO 6000 worse! Was working fine, although for hearing reasons wanted to have premium voice. Added this to my account and didn't appear. After many conversations helpdesk owned up to an issue! Whilst premium voice was loaded, wouldn't work if device was set to use units of Miles+yards or Miles+feet (only kilometres). This morning I received 3 updates and now when I select MyPlaces it shows an outline route, tries to optimise the route twice, redisplays the outline route, but the doesn't show the "Lets Go" steering wheel so can't see route step by step details - so no use whatsoever. Device therefore "bricked" - this is really appalling customer service and a technical mess! Either resolve quickly or I will be taking legal advice!!!!!!!!!!!!!!!!!
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,181
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Well, don't take legal action against us. We ARE NOT affiliated with TomTom. Just a user forum.

Customer service numbers:

United Kingdom
0845 161 0009
or 020 7387 5444

Monday-Friday:
9:00 am to 5:30 pm


Also, Try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top