Go 750 live help!

Joined
Nov 10, 2010
Messages
3
Here's a strange one if anyone can help. One day last week my 750 turned itself on after being in the drawer for 2 weeks. It kept turning on and off itself so I connected it to Tom -Tom home and did the latest updates, new map and restore.
On disconnecting, it was still the same and I had to let the battery discharge to turn off.
I would like a new one but funds are low.

Clive.
 
There was a bug in earlier models whereby the device would turn itself on exactly one week after being shut off .... but I thought later applications remedied that problem.

Do connect to Home again to make sure you are not offered even further updates.

And also make sure you clear the route every time you get to a destination.
 
There was a bug in earlier models whereby the device would turn itself on exactly one week after being shut off .... but I thought later applications remedied that problem.

Do connect to Home again to make sure you are not offered even further updates.

And also make sure you clear the route every time you get to a destination.
 
I tried another update and restore as there had been a critical update to Tom Tom home but it is still the same. I wonder if I delete Home and Download the original Home 1 if it could cure the problem. I seem to recall having to do this a couple of years ago for a similar fault.
 
No, Home 1 is not appropriate for your device. Further, the issue is with the device, not Home.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,077
Messages
196,554
Members
68,084
Latest member
Jürgen Giersberg

Latest Threads

Back
Top