Go 720 Can't See Newly Installed Map?


Joined
Jan 29, 2013
Messages
4
Location
UK
TomTom Model(s)
GO720
I have a GO 720 with the following maps:
Western Europe on the internal memory. Western US and UK & ROI on the SD card.
Yesterday I purchased an update to the UK & ROI map. All downloaded OK using TomTom Home. After running the requested software updates, I installed it to the SD card (not enough room on the internal memory) and it indicated that the job had been completed OK-no error messages. And the new version of UK & ROI showed up in TomTom Home as now installed to the SD card.
But after rebooting the 720, I could only find Western Europe on the internal memory, and Western US on the SD card (using the Switch Maps function). The original version of UK & ROI has been deleted from the device, and the new one is not detected.
I tried deleting and reinstalling it again-exactly the same issue. It's visible through TomTom Home, but not accessible on the device.
It can't be a faulty SD card, because I can access the Western US map that was already installed on there.
Can anyone help please?
 
Ad

Advertisements

Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
Sounds like it could be a job for TomTom's "ClearFlash" utility :)

Read about it and download it here:

http://uk.support.tomtom.com/app/answers/detail/a_id/6178

It's not terribly exciting to see working, in fact when you run it, it's over in a second and you barely notice anything happening at all.

No promises, but it has definitely helped with "no map found" problems before.
 
Joined
Jan 29, 2013
Messages
4
Location
UK
TomTom Model(s)
GO720
No, I haven't tried a PIN reset, as that does not appear to relate to this problem; the device is not freezing or unresponsive.
Thanks, will try the 'ClearFlash' utility.
If it's relevant, the system software it's running is version 8.351-I believe this is up-to-date?
 

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,158
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
No, it's not. 9.465 is the latest application. And a pin reset often solves various issues so please do it. No data is lost.
 
Joined
Jan 29, 2013
Messages
4
Location
UK
TomTom Model(s)
GO720
I thought that a pin reset is the equivlalent of a factory restore-it will take everything back to the originally installed sytem software, and remove all personal settings, routes etc?
 
Ad

Advertisements

Joined
Jan 29, 2013
Messages
4
Location
UK
TomTom Model(s)
GO720
OK, thanks, I will check for further updates, then run ClearFlash, and then do a pin reset if still not seeing the maps.
 
Ad

Advertisements

Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
A pin reset is only like fully turning the unit off (the power button just puts it to sleep), so it's like re-booting a PC and Windows has to re-start.

You'll find "Return to factory settings" in the menus if you ever need it.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top