New TT GO 720 can't find US map only Guam

Discussion in 'Maps and Routing' started by rhill, Dec 26, 2007.

  1. rhill

    rhill

    Joined:
    Dec 26, 2007
    Messages:
    8
    Likes Received:
    0
    Hi, I'm setting up my parents new 720 and TT Home says that the US map is on the device but when I go to pref>manage maps>switch maps the only map listed is Guam.

    I also earlier removed the Guam map at which point the device said No Maps! or something similar and was basically inoperable.

    Is the device bad or is it just user error? :D

    This is getting frustrating. Any help/advice would be greatly appreciated!!

    :confused:
     
    rhill, Dec 26, 2007
    #1
    1. Advertisements

  2. rhill

    r028806

    Joined:
    Dec 23, 2007
    Messages:
    69
    Likes Received:
    5
    No Maps

    Try running an update, to pull in the latest version of the application (Ver 7.221). Your certificate file is missing or corrupt. This will sometimes fix the problem. If not give tech support a call to assist you with this, as they do have a solution. Do not delete maps from your Tom Tom unless you back it up first.
     
    r028806, Dec 26, 2007
    #2
    1 person likes this.
    1. Advertisements

  3. rhill

    rhill

    Joined:
    Dec 26, 2007
    Messages:
    8
    Likes Received:
    0
    All available updates have been done according TT Home.

    Don't worry I've got it backed up and the maps copied to my computer.

    We've talked to tech support twice now and they have just said delete and re-install the US map. This HAS NOT WORKED. Which means it is probably a bad map file.

    So now what? :confused:
     
    rhill, Dec 26, 2007
    #3
  4. rhill

    46jimbo

    Joined:
    Dec 4, 2006
    Messages:
    1,020
    Likes Received:
    65
    Location:
    Toronto, ON
    TomTom Model(s):
    TT ONE v1
    If it's a bad map file, TomTom will send you another via download.
     
    46jimbo, Dec 26, 2007
    #4
  5. rhill

    rhill

    Joined:
    Dec 26, 2007
    Messages:
    8
    Likes Received:
    0
    Finally got a new file from tech support:

    North_America-7.meta.dct

    They said once I was able to get through/log-in to tomtom.com that there would be detailed instructions with the file. Well there wasn't :mad:

    Now what?
     
    rhill, Dec 28, 2007
    #5
  6. rhill

    Pedro2NR

    Joined:
    Aug 30, 2006
    Messages:
    5,937
    Likes Received:
    139
    Location:
    Downey, California
    TomTom Model(s):
    GO 910, ONE V2, GO 920 GO 730 & iPad TT App
    call them back and let them know this method is not working.
     
    Pedro2NR, Dec 28, 2007
    #6
  7. rhill

    rhill

    Joined:
    Dec 26, 2007
    Messages:
    8
    Likes Received:
    0
    Haha well now tech support has successfully walked through the steps of totally FUBAR'ing the unit to where it won't even turn on.

    Then they expect us to mail it back to them, then wait for them to mail a new one. Yeah right.

    Piss poor customer service
     
    rhill, Dec 29, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.