Big problem with tomtomt XL 350-M

Discussion in 'Technical Support' started by Michaellgs, Jul 17, 2011.

  1. Michaellgs

    Michaellgs

    Joined:
    Jul 17, 2010
    Messages:
    10
    Likes Received:
    0
    Last time I updated my device, I wiped the whole unit and let Tomtom Home re-download all of the most up to date stuff. It worked fine then, (like 6 months ago)

    Last night I tried the same thing. Now my device is bricked. I need help fixing it.

    My PC is Windows 7 64bit. My Device is a Tomtom XL 350-M Lifetime maps edition.

    I've reformatted the memory to FAT32 using full format, NOT quick. I ran error checking and it passes. So far, so good..
    I start up Tomtom Home

    I get a msg that says "Application update required" So I click update

    There is a brief loading screen

    Then I get a new popup which says "An error has occured"

    Error when contacting Server:You have an invalid version of the tomtom application installed on your tomtom device. To you Home you need to install the correct version of the tomtom application.

    Show details..

    ERROR: 573/#https://home.tomtom.com/account/setDevice: Error from server: You have an invalid version of the TomTom application installed on your TomTom device. To use HOME you need to install the correct version of the TomTom application.
    You have an invalid version of the TomTom application installed on your TomTom device. To use HOME you need to install the correct version of the TomTom application.
    Error code: 573
    Debug info from server: InvalidModelOrNavcoreException %3A The combination of model and navcore version provided is not supported
    URL: https://home.tomtom.com/account/setDevice
    Additional information: info = [object]
    info.func = [string] account/setDevice
    info.args = [object]
    info.args.deviceCode = [string] AK5ZEA2M9J
    info.args.deviceSerial = [string] GK1260A00929
    info.args.deviceModel = [string] one
    info.args.deviceNavcoreVersion = [string] 0.000
    info.args.deviceParameters = [string] {}

    info.method = [string] POST
    info.useCache = [string] false
    info.dryRun = [string] false
    info.xmluploadbody = [object] empty

    Severity: 1105
    Stack:
    0. chrome://tthome/content/logic/comm.js:468
    xmluploadbody: this.xmluploadbody
    1. chrome://tthome/content/logic/comm.js:430
    this._doneCallbacks();
    2. chrome://tthome/content/logic/comm.js:277
    this.request.onload = function() { me._done(true); }

    Time: Sun, 17 Jul 2011 02:46:58 GMT

    Now the weird thing is that when I look through the Home menus, it refers to my tomtomt device as "ONE", and not "XL"

    Such as Update my ONE, Read the manual for my ONE, manage my ONE, etc

    I am pretty sure before this trouble, it refered to my device as an XL. So anyways.. When I do an update, no matter how well I wipe the device or the PC of all traces of old stuff, it never downloads and updates my device with the correct software. I watched the youtube video of someone performing the same clean wip and recovery and it just doesn't work. Always get an error msg and a flashing red X

    Also, I don't know if this is related. to the problem, when I go to Tools>Use latest map guarantee, it says Your latest map guarantee has expired.. What. I thought I had lifetime maps. This error could possibly be the result of Home not identifying my device correctly though.. We'll see once I can unbrick it.
     
    Michaellgs, Jul 17, 2011
    #1
    1. Advertisements

  2. Michaellgs

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,985
    Likes Received:
    442
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    If you restore your backup, what happens?

    Lifetime maps are offered by the Update my Device when they are available, not the LMG.
     
    dhn, Jul 17, 2011
    #2
    1. Advertisements

  3. Michaellgs

    Michaellgs

    Joined:
    Jul 17, 2010
    Messages:
    10
    Likes Received:
    0
    I don;t have a back up :/
     
    Michaellgs, Jul 17, 2011
    #3
  4. Michaellgs

    Andy_P Moderator

    Joined:
    Feb 11, 2011
    Messages:
    4,683
    Likes Received:
    36
    Location:
    London, UK.
    TomTom Model(s):
    Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
    Oh.... not so good.

    As you probably now realise, backups are VITAL, especially if you are going to start wiping and formatting!

    There's normally no need to do that just to do an update, but you STILL need to make backups before doing any updating at all,

    And if you didn't have lifetime map updates, there would be no way to recover your maps without a backup either.

    Anyway, lecture over.... the next step I would try is to install a version of software manually.

    So we can suggest the right version to try, do you know what exact model you have? (ONE XL, XL 30 series, XL IQ Routes, XL2?).
    To find out, put the first two characters of your serial number into the box on this page:
    Which TomTom device do I have?
     
    Andy_P, Jul 17, 2011
    #4
  5. Michaellgs

    Michaellgs

    Joined:
    Jul 17, 2010
    Messages:
    10
    Likes Received:
    0
    Xl 350 - 2gb tts
     
    Michaellgs, Jul 18, 2011
    #5
  6. Michaellgs

    Andy_P Moderator

    Joined:
    Feb 11, 2011
    Messages:
    4,683
    Likes Received:
    36
    Location:
    London, UK.
    TomTom Model(s):
    Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
    I reckon that would be v9.151 or v9.161 then, but wait to get confirmation from one of the NA regulars here as I'm more used to the European models.
     
    Andy_P, Jul 18, 2011
    #6
  7. Michaellgs

    Michaellgs

    Joined:
    Jul 17, 2010
    Messages:
    10
    Likes Received:
    0
    Where would I Download that from to do a manual install on my device.
     
    Michaellgs, Jul 18, 2011
    #7
  8. Michaellgs

    Michaellgs

    Joined:
    Jul 17, 2010
    Messages:
    10
    Likes Received:
    0
    Ok, I googled your version numbers and found a list of downloads from official tomtom website. By looking at the numbers, I decided to try this one:

    http://download.tomtom.com/sweet/navcore/9.103.gk.CAB-navcore-XL.cab

    I unzipped and copied the contents onto the internal memory of the device. It now boots up and tells me theres no maps.. Way better than a red flashing X

    The problem is that Home Still thinks my XL is a ONE, so my lifetime maps subscription, or for that matter nothing is showing up in the update section. I think if we can figure out Why the device is being recognized incorrectly, Then it will work like its supposed to.

    To tell you the truth, I think it has been calling my device a ONE for a long time now. Because I have never been able to take advantage of my lifetime maps. The only it ever updated were map share corrections, which are a few MB, It never downloaded a new map, which are several hundred MBs.
     
    Michaellgs, Jul 18, 2011
    #8
  9. Michaellgs

    Michaellgs

    Joined:
    Jul 17, 2010
    Messages:
    10
    Likes Received:
    0
    Ok, I booted up the device and held the button for a long time until a bunch of text appeared:

    TomTom ONE (TM) (c) TomTom 2003-2010 Build -N/A-
    Hardware type: TomTom XL
    SubID (feature) 0 1: 00 (0000000D00000000)
    Bootload version: S5.5279 clist#575098 RVCT
    Checksum:E2F6
    Memory: 64 MB , Type:MDDR
    CPU ID:32450003
    Clocks: 264.0 132.0 66.0
    GPS type: GL2 BCM4750 FFFF
    TFT type: Samsung LMS430HF19 17
    Internal FLASH capacity: 2007040
    MMC NAND version (PRV): 36 48.0 MHz 4 B Samsung
    Startup mode: Power down
    Device ID: GK**********(censored by me, just in case)
    ...few more which are probably irrelevant
     
    Michaellgs, Jul 18, 2011
    #9
  10. Michaellgs

    Michaellgs

    Joined:
    Jul 17, 2010
    Messages:
    10
    Likes Received:
    0
    Well, I just got off the phone with tech support. Good news.

    After going through the standard procedure of rewiping the device and doing a fresh installation. As I've already tried dozens of times before. The tech on the phone told me to hold for a few minutes while he checked something.

    Apparently there is a problem with the servers, and thats why my device is not updating correctly. He gave me a reference number for my case and told me he will call back in a few hours to finish.
     
    Michaellgs, Jul 18, 2011
    #10
  11. Michaellgs

    Michaellgs

    Joined:
    Jul 17, 2010
    Messages:
    10
    Likes Received:
    0
    Ok, update:
    On Monday, July 18th, 2011. I called tech support to try and resolve my issues. We went through all of the troubleshooting steps and after 2 calls. We determined it was defective. They set up an RMA for me and I shipped the unit to them via UPS that same day at around 4:00pm

    Today is Thursday and I just received the refurbished unit. It came with all of the accesories, and I still have the accessories from my old device. Wow. This will make it easy to transfer between vehicles.

    But I am amazed that the turn around was just a mere 3 days. Very impressive. Also The new unit seems to work great, it was a bit dusty, but it cleaned right up with a microfiber cloth

    Also I hooked it up to my PC and it let me transfer my account to the new device. I am doing a full explorer backup. Then I will update it to the latest map.

    TomTom, You amaze me.
     
    Michaellgs, Jul 21, 2011
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.