720 not recognizing memory chip

Oct 21, 2009
I have a 720 thatI have been using for a while here in the US.

I bought a Transcend MMCplus 4GB memory card. I formatted it using Fat32.

Tried a few times backing up and then restoring with the crd in the device, but each time it restores to the device.

Next, tried copying the Europe maps to the chip independently and then inserting it into device to see if it would recognize it - no luck. Then tried same with MP3s, following advice in forum regarding caps use, etc.
Still can't gethe device to recognize the chip.

My ultimate goal? Get US maps, Europe maps and some MPs onto the 4 GB memory chip.

What am I missing?

Thanks for the great forum!


Sounds as if you are missing a proper card. It should be a sdhc card, the fastest speed the better (at least class 4). and get it from a reliable company; too many offered on ebay are scams.......


Ensure also you have the latest TT software on the GPS. Older sw could not read cards bigger than 2gb.
I run a 8gb in mine fine. Lower speed shouldn't be a problem as far as I know for access but might do weird stuff if you use the card for maps.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question