6200 truck nav wont restore

Joined
Sep 6, 2023
Messages
3
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Go professional 6200
Hi my sat nave has come up on display with a computer screen a Red Cross and a cable to the sat nav. I have tried the drum roll reset to no avail and also tried to restore with no joy any help would be appreciated
 

Use the 2nd procedure for "recovery". First be sure you have the MyDrive Connect app installed on your PC.

If no joy with recovery, please tell us how and where you get stuck in the process.
 
I have tried second recovery. The one thing that doesn’t happen is after pressing the power button three times I don’t get a spinning cog, the screen goes blank then the computer and device with a Red Cross in between appears. On the my connect it shows that the device is being recovered but once it hits 100% it reboots the nav but returns to the back to the cross display.
 

Use the 2nd procedure for "recovery". First be sure you have the MyDrive Connect app installed on your PC.

If no joy with recovery, please tell us how and where you get stuck in the process

Use the 2nd procedure for "recovery". First be sure you have the MyDrive Connect app installed on your PC.

If no joy with recovery, please tell us how and where you get stuck in the process.
I have tried second recovery. The one thing that doesn’t happen is after pressing the power button three times I don’t get a spinning cog, the screen goes blank then the computer and device with a Red Cross in between appears. On the my connect it shows that the device is being recovered but once it hits 100% it reboots the nav but returns to the back to the cross display.
 
I am having the exact problem as you with my go6200. Your attempts mirror my attempts. I attempted to contact customer service but ran into an AI service. Ran around in rings with it, stupid doesnt describe its abilities, but eventually I got the option to get human support after clicking ther thumbs down button several times to tell it I wasnt happy with its help. Clicked on the speak to a human button, described my problem and sent it. I got an automated response saying someone will contact me within 2 days. Tomorrow is 2 days so we will see. If I do get a response and maybe a solution I will let you know what transpired. cheers William
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
28,866
Messages
194,746
Members
67,813
Latest member
Cumbrian

Latest Threads

Back
Top