Rider 500. Phone calls and voice commands problem

Joined
Aug 2, 2020
Messages
2
Country
<img src="/styles/default/custom/flags/it.png" alt="Italy" /> Italy
TomTom Model(s)
Rider 500
I have a new Rider 500 purchased 1 week ago. With both Samsung S10 + and Note 8+ the management of phone calls and voice commands does not work. When a call is received, the answer and reject buttons appear on the navigator, pressing them nothing happens, the two buttons disappear and the phone continues to ring. The voice command button on the navigator opens the phone's voice assistant only if the Mydrive application is open and with the phone display on, in all other conditions, pressing this button has no effect. I made many attempts but it never worked; seems to be a common problem. Do you have information on how to solve the problem?
Thank you
 
Welcome to TomTomForums.

I do not know your Rider 500 but, did you Bluetooth pair them properly, per instructions?
 
Welcome to TomTomForums.

I do not know your Rider 500 but, did you Bluetooth pair them properly, per instructions?

Yes, everything works (text messages, notifications, music, etc..) except calls and voice commands.
 
Reading through the manual, it seems you have to answer/reject calls via your headset. It says caller can be identified on the 500 screen, but I had hoped the safer option of tapping the answer/reject button on the screen would be an option. I gotta say it's disappointing. Why are the red/green buttons there?
 
I have a new Rider 500 purchased 1 week ago. With both Samsung S10 + and Note 8+ the management of phone calls and voice commands does not work. When a call is received, the answer and reject buttons appear on the navigator, pressing them nothing happens, the two buttons disappear and the phone continues to ring. The voice command button on the navigator opens the phone's voice assistant only if the Mydrive application is open and with the phone display on, in all other conditions, pressing this button has no effect. I made many attempts but it never worked; seems to be a common problem. Do you have information on how to solve the problem?
Thank you
Hello. I have exactly the same problem with a Rider550 connected to an Interphone headset and Samsung S20 phone. All devices are connected corectly and factory resets have been done. When somebody rings me I can see the green and red phone symbols on my TomTom screen. I touch the green symbol to accept the incoming call. Both symbols dissapear and the phone just contiues to ring. Did you find a solution?
 
Set your phone to automatic answer when connected to a bluetooth headset.
Thank you. As a last resort I was going to set the phone to automatic answer but i would prefer to select, accept or decline on the sat nav screen if that was possible. I have emailed TomTom for an answer as I believe the problem is with the TomTom
 
I have exactly the same problem on a RIDER 550, and no solution!
But it has been working fully, but nomore.
That is: activating the Google Assistant by clicking the Phone icon on the GPS, making phone calls, asking questions, playing music with voice commands and listening thru the helmet headset.
The difference now is that it only works when the MyDrive-app is active, visible and screen turned on, on the phone.
And that is of course never the case when riding the bike.

Is nobody from TomTom reading this forum?
 
I have exactly the same problem on a RIDER 550, and no solution!
But it has been working fully, but nomore.
That is: activating the Google Assistant by clicking the Phone icon on the GPS, making phone calls, asking questions, playing music with voice commands and listening thru the helmet headset.
The difference now is that it only works when the MyDrive-app is active, visible and screen turned on, on the phone.
And that is of course never the case when riding the bike.

Is nobody from TomTom reading this forum?
Hello JohanSWE
I did send TomTom about 20 emails about this concern. They have not provided an explanation and they eventually stopped replying. They spent most of the time talking about relationships and compatibility of devices. I suggested that the concern is between the Rider 550 and the phone (i.e. the Rider does not send a signal or a compatible signal to my phone for it to accept an incoming call whereas pressing my headset button it will activate my phone to accept an incoming call). I have not been able to find an answer wether it be a glitch in the TomTom software or compatibility of devices. Good luck.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
28,976
Messages
195,679
Members
67,959
Latest member
31Den

Latest Threads

Back
Top